USB Device over current detected

November 28, 2007 at 01:30:59
Specs: Win XP Pro, AM2 Athlon X2 3800+, 2GB

Problem:
I can no longer run the computer with USB 2.0 controller enabled through the BIOS... the problem started suddenly about a month ago when i turned the system on... the computer is roughly 5 months old

When i start the computer with USB 2.0 Controller enabled i get the following message

Warning!!! USB device over current detected!!!
Please remove over-current USB Device!!!
System will shutdown in __ seconds!!!

The system then shuts off, this happens before windows boots at the end of or just after the post sequence.

I have tried:
-Removing all USB devices from the system..
-Updateing the BIOS

Neither of the above worked

The only solution i have found to work so far is to disable USB 2.0 in the BIOS... however that leaves me with the abysmal transfer speeds of USB1.0/1.1 which is just plain painful....

Here are my computers specs:
AM2 Athlon X2 3800+
2GB 667Mhz DDR2 Corsair Value
Asus M2A-VM-HDMI Motherboard (AMD 690G Chipset)
Inno3D 8600GT 256MB

Photos/Screenshots:
http://i17.tinypic.com/86gpg0h.jpg
Screenshot of the Error

http://i18.tinypic.com/6okfds1.jpg
Screenshot of the BIOS Screen / USB Controller option

Any Help or Suggestions are greatly appreciated..
Cheers
Nic


See More: USB Device over current detected

Report •


#1
November 28, 2007 at 08:50:51

Sure sounds like the enhanced USB controller is defective. If the MBoard is under warranty you might contact the manufacturer. If this is some sort of defect they may have a solution.

Is this controller integrated or on a breakout bracket connected to a header? Just thinking that if it is a header there may be a short in the wiring somewhere.


Report •

#2
November 28, 2007 at 09:14:45

"I have tried:
-Removing all USB devices from the system.."

Did you unplug them all?

"-Updateing the BIOS"

Never flash your bios unless you find specific information in release notes for the update that mention the problem you are having.
Besides, it sounds like you weren't getting the message previously when the USB 2.0 controllers were enabled, so there was nothing wrong with the bios version you had.

Go into you bios Setup and check the current voltages. If any of +3.3v, +5v, or +12v
are not within 5 to 10% of their nominal value, your power supply is defective and must be replaced before it damages your mboard, assuming it hasn't already. If +5v is out of whack, the USB controllers won't work properly; if it is too high, that will eventually damage them.


If the voltages seem okay, or in any case....

Remove the AC to the computer/power supply.
Pull off all connections inside the case to USB headers on the mboard.
Unplug all USB connected devices.
Restore power.
Enable USB 2.0 controllers in the bios Setup.
Try the computer.
- If you still get the overcurrent message, the mboard is defective. You will have to either leave USB 2.0 controllers turned off in the bios Setup, and get a USB 2.0 controller card to connect USB 2.0 devices to, or replace the mboard.
- If the overcurrent message no longer appears, you need to connect to the mboard USB header(s) differently. (don't connect to any 5th pin, a second ground or overcurrent pin, for a USB port on the mboard header)
......

Also - a possibility.
Some mboards, e.g. Asus, have identical headers and pin arrangements for two port USB headers and firewire headers. Make sure you don't have the USB wiring connected to a firewire header, or visa versa. There is no immediate problem when no device is connected to a port, but when a device is plugged in it will damage the mboard circuits and possibly the device you plugged in.


Report •

#3
November 28, 2007 at 09:49:44

Thank you for your replies. They are greatly appreciated... I will indeed look into your suggestions further. There are also a few things i should add.

My power supply is an Antec Neo 550W
looking into the voltages the +5V is stable at 4.76-4.78V the +12V and 3.3V rail are stable at 11.97 and 3.26

The front USB ports are correctly connected, they have been functioning fine for the last 5 months ... however i will try disconnecting the front ports from the motherboard to see if that makes any difference...

I unplugged all USB devices including keyboard and mouse which i swapped for older ps2 ones... however i did not remove the connectors from the motherboard to the case's front USB ports.

Cheers
Nic


Report •

Related Solutions

#4
November 28, 2007 at 11:02:06

Your PS voltages are fine. Antec makes excellent PSs that are almost always trouble free.
If you have one or more firewire headers, make sure you connect the USB wiring to the USB headers.

If you find the mboard is defective after trying the above, and you're sure you've never connected USB or firewire wiring to the wrong header or connected to the 5th pin on a header for a USB port (or you did but previously had no problems), if your mboard is still within it's warranty period, you should have no problem RMA ing it - see the Asus web site, or some sellers have an over the counter swap arrangement if it is less than a certain time since you bought it.


Report •

#5
November 28, 2007 at 11:20:28

Verify one or more pieces of your USB external hardware are not defective. Not sure if that could have damaged the controller or not. Look at your manual to determine which of your headers is enhanced USB and disconnect the connectors from those headers. Then Enable the USB 2.0 ports in the BIOS to see if the same message persists. If not, then there is a problem with the wiring or the ports themselves. This would mean you wouldn't have a MBoard problem, hopefully.

Report •

#6
November 28, 2007 at 22:27:50

Thanks guys...
tested system with front ports disconnected and on another header.. nothing... confirmed that the USB ports for the front panel where correctly connected to the header on the motherboard... at this point everything is pointing towards a faulty motherboard..

Googleing this error provides only a little information.. most results are not in English and the ones that are have usually gone unanswered. Though most / if not all of the people getting this error seem to have Asus motherboards... which leads me to think there might be a possibility that this is an unfixed bug in their BIOS's or a rare defect that effects a small number of boards… There are 2 threads on this error in the Asus forums one for my motherboard with no replies and the second is for the P5W DH Deluxe motherboard and offers up a Modded 3rd party bios as a supposed fix for the issue…

thanks again for all your support.


Report •

#7
November 29, 2007 at 09:02:26

If you weren't getting the error before with USB 2.0 controllers enabled in the bios, obviously it's not a bios problem in your case.

Usually this error is caused by connecting a second ground connection (for the shell - outside metal of the port) for a USB port from the case or a USB wiring adapter in a slot to a 5th pin for overcurrent or ground for a USB port on the mboard header.
Removing all connections to the USB header(s) on the mboard removes that possibilty, and you have said there was no problem previously with the way your case wiring front USB is wired.

Unplugging all USB devices eliminates the very unlikely possibilty you have a damaged USB device that is causing the problem.

The only thing left is a damaged mboard, if the USB 2.0 controller(s) is (are) built into the mboard.


Report •


Ask Question