USB Device Not Recognised!

February 1, 2011 at 19:49:51
Specs: Windows 7, Pentium E5400/2GB DDR2 800Mhz
I am running Windows 7 Ultimate 32 bit and have recently bought a new USB foot pedal. But when I plug it in, it says usb device not recognised and the drivers are not installing so I can't use it. I thought there might be a problem with it and tried it on a friend's computer running windows xp and it worked. I thought there might have been a compatility problem with windows 7 and installed XP on a dual boot. But even then, it still won't work.

I know for sure that my USB ports were working because I have used pendrives all the time and USB keyboard and mouse.

The device manager list my USB foot pedal as unknown device. I have searched about this problem all over the net, tried all the suggestions therein but still the problem persist.

I simply don't know what to do!

Any suggestion would be absolutely welcomed.

Thank you guys.

Ignorance Is Bliss!


See More: USB Device Not Recognised!

Report •


#1
February 1, 2011 at 19:58:54
I'd bet telling us the brand and model of this foot pedal may help.

"The era of big government is over," said Clinton 1996


Report •

#2
February 1, 2011 at 20:22:26
Thanks for the reply. I will post the link here it is:

http://www.rajorienindustries.com/i...

If anybody could help, that would be much appreciated. I'm on the verge of buying a new motherboard as I know that the foot pedal is working with other system.

I have contacted the manufacturers but they seem to be as mystified by it as I am, as to why it didn't work on my system!

Ignorance Is Bliss!


Report •

#3
February 2, 2011 at 14:21:27
Here is the problem. "unknown device." Windows may have a number of built in drivers for both specific and generic devices. I can pretty much guess that Windows doesn't have a specific driver for that. It may be that some generic mmi or human interface should be used but you need to get the maker of the foot switch to tell how it is supposed to work.

Either they need to supply a driver of the switch is supposed to use generic drivers.

"The era of big government is over," said Clinton 1996


Report •

Related Solutions

#4
February 2, 2011 at 21:38:25
Yes, actually in Device Manager in usb root hub (or something like that) it is listed as unknown device. It is a plug and play device and the driver should have been loaded automatically but it is not. I have tried on all the available usb ports in the front as well as the back and it says "driver has not been loaded or one of the usb device has malfunctioned.." something like that.

I am totally at a loss. If it works on other system why doesn't it work in mine? NOt only that, my pendrive and all the other usb products that I have tried works.

Is it possible to download any driver manually without using the update driver option in Dev manager?

Thanks for the reply again.

Ignorance Is Bliss!


Report •

#5
March 22, 2011 at 22:11:58
Hello:

Please try this, it will solve your problem. Try this link

http://support.microsoft.com/kb/925196

Click Fix It icon in it and let it run.

It solved my problem (same problem). Do not change motherboard. Let me know in reply if this solved your problem.


Report •


Ask Question