Tower beeps three times, monitor says no signal

April 15, 2015 at 10:25:43
Specs: Asus
I've had the same tower for a few years now. The other day whilst gaming it was running smoothly wasn't cutting out or anything and today I went to start my computer and the screen said no signal. I tried restarting it, making sure all the wires were right, everything, still nothing happened however my keyboard and mouse were still lit up. After restarting numerous times testing other wires still nothing then I heard two beeps but still nothing happened the final time I restarted my computer there was one slow beep then shortly after two other beeps closely together. I don't know what to do or to fix it, can somebody shed some light on the problem please?

See More: Tower beeps three times, monitor says no signal

Report •

April 15, 2015 at 13:15:17
Let us have the model number of your computer please.

In the meantime here is a general website for Asus beep codes:

It looks like a RAM fault. First try removing the RAM stick(s) and cleaning the edge connectors with a pencil eraser. Pop the stick(s) in and out a few times to clear any oxide off the sockets. This often clears the problem but if you are not so lucky then try one stick of RAM on it's own in first position. By swapping the stick in the same position you should be able to determine which one is at fault.

Otherwise here is a RAM test:
Use the free version.

Always pop back and let us know the outcome - thanks

Report •
Related Solutions

Ask Question