Toshiba Satellite M55-S135 Screen Repair

April 12, 2010 at 17:42:09
Specs: Windows XP
I have a Toshiba Satellite M55-S135. I found
information that led me to believe I was having
a problem with my backlight inverter. On
startup the picture would flicker for a few
seconds then go out. I ordered a backlight
inverter for my laptop and it did not illuminate
the screen. The old one did but continued to
go out. I got another one and installed it. The
backlight now seems to illuminate the screen
but no images come up. I can here the
computer starting up and the sound of the
windows screen sounds but nothing shows up
on screen. Now when I tried reinstalling the old
inverter it does the same thing as the new one.
Any suggestions?

See More: Toshiba Satellite M55-S135 Screen Repair

Report •

April 12, 2010 at 19:49:14
Either you installed it wrong or the CCFL tube was the culprit.. either on can cause the same symptoms and testing is necessary to locate the bad component.

Check and recheck all connections from Motherboard toDisplay, and ensure you did not omitt the ground wire inside the Lid. Grounds in the newer Laptops are getting harder to work with due to the replacement of metal parts with Plastic that has a thin-film Metal deposition layer that provides some of the circuitry. (copper color is the clue)

There is nothing to learn from someone who already agrees with you.

Report •

April 13, 2010 at 03:39:04
... this maybe of interest read click >> #Response Number 8


... Posting is provided "AS IS" with no warranties

Report •

Related Solutions

Ask Question