Toshiba Satellite L300 Boot Failure

Toshiba Pslb8u-0y504h
January 3, 2011 at 10:58:07
Specs: Windows Vista
This is a friend's computer that is stuck at the initial boot screen. The screen displays the "Toshiba Leading Innovation" logo in the center, the "Insyde H2 Bios" logo in the bottom left and the Intel logo in the bottom right. This is the first thing that appears when the system is powered on, and it never progresses past this screen.

There is no option to enter BIOS setup (even pressing and holding F2 or F12 doesn't seem to make any difference). With this in mind, the system will not load an OS or a boot disk of any kind. It makes no attempt to boot from any source.

I am curious if resetting the BIOS with the RTC battery and jumpers is a possible solution. If so, does anyone have an idea of where these two are located?

I would appreciate any suggestions.

See More: Toshiba Satellite L300 Boot Failure

Report •

January 11, 2011 at 23:28:36
I'm having the exact same problem on a 2 1/2 week old Toshiba Satellite L655 S5096 that I bought my daughter for Christmas. I believe this occurred after a hard shut down. If I understand correctly there is no way to access BIOS on this machine at boot up. It also will not boot from a repair disc I made from her sisters identical machine. Is there a keystroke to make the machine boot from a CD/DVD like on a MAC? If there are two of us with this same problem there must be more.
Any help would be much appreciated.

Report •
Related Solutions

Ask Question