toshiba laptop display problems

January 28, 2011 at 14:20:50
Specs: Vista, AMD/2 Gig
I have an older A215-S4697 running Vista. Upon startup the LCD screen is nice and bright but after 75 seconds or so, it dims to a dull, almost power-saver mode. I can't seem to get it to stay bright. I always run it at 100% power off house current and the ATI Radon x1200 doesn't seem to give me any help. All drivers are up-to-date. Any help?

See More: toshiba laptop display problems

Report •

January 29, 2011 at 07:47:23
Everyone, I ran across a similar discussion posted on this forum. It appears that my issue is either the backlight or the inverter. I suppose I can just live with this problem as I'm not inclined to start a do-it-yourself task of replacing backlights and swapping expensive inverters with no guarantee that either will permenantly solve the problem. I DID plug a monitor into the laptop and it did not drop into the 'dim' mode after the first minute like the re-booted laptop.

I'll check back here periodically but I'm going to consider this issue mute at this point. Thanks

Report •

January 29, 2011 at 09:11:49
Hold the phone! I was playing with the ATI Catalyst Converter settings trying to make the most of living with this dim screen syndrome and stumbled upon an answer that surprised me. I hit Restore Factory Defaults under the Preferences tab and the screen immediately brightened to full capcity and remained that way. I have had this issue from the moment I purchased this computer so I don't know how a setting got changed that was causing my screen to darken and go dim after 60 seconds but it must have been something within Catalyst. Go figure. That cracks me up. Talk about dumb luck.

Report •

Related Solutions

Ask Question