Thermaltake PSU not powering up?

August 11, 2011 at 06:56:27
Specs: Windows 7, AMD x6 1100t
Hi,

I have just built a brand new system and my PSU will only power up my case and fans.

My system is Coolmaster HAF 912, gigibyte GA-990FXA-UD5, AMD x6 1100t, HIS HD6790 1 GB graphics, 1 TB WD black HDD, ASUS DVD burner and Thermaltake tought power XT 775.

My problem is,when I power up my unit, all lights and fans kick in on my case and the lights on my PSU light up with: Standby...... Green, PG signal ..... RED and temperature light is gree.

Anybody know the meaning of this lighting combination?

Thank you in advance,

Ger


See More: Thermaltake PSU not powering up?

Report •


#1
August 11, 2011 at 06:57:38
oh and i have 8 GB of RAM

Report •

#2
August 11, 2011 at 07:23:26
What makes you think the PSU is the problem? Did you benchtest your hardware before installing it in the case? If not, you broke the #1 rule of PC building 101.

http://www.techsupportforum.com/for...


Report •

#3
August 11, 2011 at 14:42:32
This is while testing on my table. I'm not suggesting the psu is the problem, just wondering what the light combination means, if i'm doing something simply wrong.

This is my first complete build from beginning to end (as sudden as that has been). i do have some experience with electronics but thought i'd give pc building a go.

i actually didn't realise that this "bench testing" was needed. as i am pretty anal about going over things time and time again before "firing up", this was my way of testing my equipment before disposing of packaging.

(and i have been supper anal about this setup because its my first and its not the cheapest of equipment.)


Report •

Related Solutions


Ask Question