Solved TestDisk did not read 2nd Internal HDD

August 21, 2011 at 12:22:01
Specs: Windows 7, AMD Phenom9850 Quad Core 2.5 GHZ/8GB
TestDisk did not detect bad HDD.

My OS is Windows 7. ASUS M4A785-M MB, 1 Seagate external HDD and 2 Seagate internal HDDs. Use 1 for OS and program files and 2nd for files, photos, and all documents.

2nd HDD is not detected in boot process or disk management. It does not show in BIOS either. It's as though it does not exist. Since the disappearance of 2nd HDD, boot process seems to be slower than normal. Have tried "seagate tools" and other things; including TestDisk. Nothing seems to recognize the 2nd HDD.


See More: TestDisk did not read 2nd Internal HDD

Report •

August 21, 2011 at 12:58:11
You could go into the bios and make sure the second Sata port is enabled. I would try a new sata cable and check the connections. Not likely a sata port has gone bad on the mobo, but you never know. It could be that the drive just fizzed.

Report •

August 21, 2011 at 13:42:22
✔ Best Answer
Testdisk doesn't help drives that can't be mounted. It helps recover files from mountable drives.

For the most part all hard drives HAVE to show in bios.

Check power and cables or replace both and try again. If not then send off for recovery.

1/3 of highway deaths are caused by drunks. The rest are by people who can't drive any better than a drunk.

Report •

August 21, 2011 at 14:35:05
I kinda think it might be the cable; everything else works great. I will have to wait until I can purchase another sata cable. I have all kinds of extra cables but the one I need. Of course, I do realize it could be the HDD.

Thank you so much!

Report •

Related Solutions

Ask Question