t3256 emachine problems no signal

April 19, 2011 at 19:45:30
Specs: N/A
Turned off everything was fine , restarted next day, computer sounds like I
Normal get a no signal message on screen

See More: t3256 emachine problems no signal

Report •

April 19, 2011 at 19:56:46
emachines desktop computers usually have a BESTEC power supply.
BESTEC power supplies have a reputation of malfunctioning and failing a lot more often than average, and when they do that, they are a lot more likely than average to damage something else, especially when they fail completely, often the mboard.

A BESTEC power supply malfunctioning or failing is probably the NUMBER ONE REASON an emachines desktop system fails to boot normally !

If you DO have a BESTEC power supply, that's probably what is causing your problem.
If you remove it before it gets any worse and try a known good power supply with the system, if you are fortunate and the BESTEC power supply hasn't already damaged the mboard, the system will work fine.

If you can borrow a power supply from another working computer, try connecting that.

If it is failing, you can usually replace it with any decent quality standard sized standard ATX PS with the same capacity or greater.

Standard (PS/2) power supply size - 86mm high, 150mm wide, 140mm deep, or 3 3/8" h x 5 7/8" w x 5 1/2" d , or very close to that, though the depth can be more or less for some PSs.

Don't buy an el-cheapo (in quality) PS.
See response 3 in this:

Note - I may have mentioned Coolermaster in that - I have recently found some models have only a 1 year warranty, some are known to have premature fan failures, some are known to develop failing electrolytic capacitors.


Report •
Related Solutions

Ask Question