Articles

Still slow USB hard drive transfer

Cicero
August 5, 2007 at 10:39:39
Specs: Windows XP Home Edition S, P4 2.4 MHz Prescott, 800

Hello,

I previously posted a topic here regarding the slow transfer speed of my USB hard drive, averaging 2.7 megabytes per second. The speed is faster than the theoretical maximum for USB full-speed, so I have concluded that it must be USB 2.0 hi-speed, in which case it's annoyingly slow.

I've tried unplugging my printer and graphics tablet (the only other USB devices I have), and plugging it into a back port, to no avail. I'm not sure if I tried plugging it into the back port without the two devices—could that make any difference?

Any ideas on how to increase the transfer speed? I know that one will rarely achieve the theoretical speed limit, but 3 Mbytes/s seems oddly low, and it's a pain to transfer large amounts of data.

For the original thread, see: http://computing.net/hardware/.../47662.html

Thanks,


--Laogeodritt


See More: Still slow USB hard drive transfer

Report •


#1
August 5, 2007 at 12:08:24

Laogeodritt

I tried assisting you in the original thread.
Check the date and version of the driver for the Enhanced controller. Mine is 6-1-2002/ 5.1.2600.0


Report •

#2
August 5, 2007 at 13:07:05

What is your speed copying between internal hard drives?

Report •

#3
August 5, 2007 at 14:52:37

"What is your speed copying between internal hard drives?"

He answered that in the original thread - about 33mb/sec.
.......

If your mboard supports USB 2.0, USB 2.0 has a slower mode and a faster mode. Sometimes it is set to the slower of the two modes in the bios Setup by default - have you checked there, and if that is there, tried the other mode?

Make sure your external drive is is set to a mode other than PIO by Windows. If it is in PIO mode, try resetting it.
http://www.microsoft.com/whdc/devic...

Some computer cases have USB ports with wiring that doesn't actually support maximum USB 2.0 max data transfer speeds - in that case you are more likely to achieve faster data transfer speeds if you plug into a USB 2.0 port directly connected to the mboard.
Similarly, the USB cable between the external hard drive and the USB port must actually support maximum USB 2.0 max data transfer speeds - if the packaging for the USB cable did not specify it meets USB 2.0 requirements, or if it was a cheap one (it may be a lie), it may not be capable of the task.
Similarly, if you have the USB cable from the external drive plugged into a USB hub, and the hub is plugged into a USB 2.0 port, the hub must support USB 2.0 properly, and if there is anything else plugged into the hub the data transfer speed is reduced if any other device is transferring data at the same time.

As OtheHill pointed out, your mboard may have a combination of USB 1.x only and USB 2.0 ports, so not every port may support USB 2.0. All USB 2.0 is backward compatible with USB 1.x , so you will find both regular and enhanced or 2.0 controllers listed in Device Manager, whether you have a combination of USB 1.x only and USB 2.0 ports, or only USB 2.0 ports that are backward compatible with USB 1.x. Whether you have any USB 1.x only ports would be in your mboard manual.


Report •

Related Solutions

#4
August 6, 2007 at 19:30:49

OtheHill: Same as you: 2002-06-01, 5.1.2600.0.

Tubesandwires: There is an option to set HiSpeed or Fullspeed mode in the BIOS, according to the manual. I'll check that tomorrow along with the transfer mode of the device (DMA or PIO)... that can be checked / applies despite the USB enclosure, right?

I've tried plugging it into a back port (albeit I didn't unplug the printer, which was off, and the graphics tablet), and it made no difference. I didn't try all of them.

The cable came with the enclosure, if I recall correctly. The box specified "USB 2.0" specifically, and I think it specified "Hi-speed" but I can't recall. I can't find the box. The enclosure has a "USB 2.0" sticker near the USB A female port.

If it's any help, the cable has the following printed: "[odd symbol] AWM E89980-A SUNF PU STYLE 2725 80°C 30V VW-1 28AWG/1P 24AWG/2C USB 2.0 CABLE TID 60000103".

I'm going to try my printer cable too, which I bought separately—it's been three years, I can't recall the brand or anything, but the connectors are gold-plated if that tells you anything.

As for the motherboard ports, the manual states the following:
"7. USB 2.0 ports 3 and 4. These two 4-pin Universal Serial Bus (USB) ports are available for connecting USB 2.0 devices.
"8. USB 2.0 ports 1 and 2. These two 4-pin Universal Serial Bus (USB) ports are available for connecting USB 2.0 devices."


I'll post tomorrow with results.

--Laogeodritt


Report •

#5
August 6, 2007 at 19:34:58

Did you install the harddrive into the enclosure? What is the size, brand and model of the harddrive? Did you read the enclosure directions concerning what jumper setting to use

Report •

#6
August 6, 2007 at 19:51:54

How would I be accessing it via the enclosure if I didn't install it? =P

It's a Western Digital Caviar SE EIDE hard drive.

Model: WD2000JB—00KFA0.

200 GB.

I usually always read the instructions. I can't find them right now so I can't double check, but the jumper is set for Master.

--Laogeodritt


Report •

#7
August 7, 2007 at 04:02:40

Western Digital drives usually have TWO Master settings. One for Master alone and one for Master with slave. I don't know if that would make any difference. Just trying to find a solution for you.
"How would I be accessing it via the enclosure if I didn't install it? =P"

You could have bought the drive and enclosure already assembled. Many folks do that. I am looking for incompatibilities. At one point some time ago there were many External enclosures on the market that would not acept harddrives larger than 127GB.

Whatever type of circuitry is inside the Enclosure needs to be 48bit LBA compliant.

Look at the link below for an explanation of this.

http://www.48bitlba.com/index.htm


Report •

#8
August 7, 2007 at 10:31:35

Hmm. I have it set as Master with Slave, rather than Single/Master ... I just found the instructions and it doesn't mention installing a drive into a casing, just drivers and formatting.

Would the drive work at all if it were incorrect? Should I try Single or Cable Select?

Is there any way to know whether it supports 48-bit LBA? I see nothing that clearly could indicate it.

However, if it's of any help, the enclosure reports a 2TB drive (it's 200 GB); the tech at the store I bought it from (a small computer shop) told me that that's normal and that I should just format the drive by hooking it up directly to the computer, which I did. I'm still sceptical, but I couldn't refute it.

--Laogeodritt


Report •

#9
August 7, 2007 at 10:44:16

I only mentioned the 48bit LBA in case you got hold of an older enclosure. I don't really know if the jumper has nay affect or if it would even work if set differently.

When you look at the drive in My Computer what size is reported?

I have a WD 320GB in an Enclosure that I installed to. In "My Computer" the drive is Identified as "DRV_4" and "Local disk", Size 298GB. That is correct formatted size.

If your drive is not properly identified in My computer then maybe it is a enclosure or jumper issue.


Report •

#10
August 7, 2007 at 11:05:15

...

I think I just got it.

I took out the jumper (no jumper = Single/Master mode) and now I'm getting speeds of 18-22 KB/s average.

Thank you very much for your help, OtheHill! And thanks for responding, aegis and Tubesandwires.

--Laogeodritt


Report •

#11
August 7, 2007 at 11:07:21

There you go.

Report •

#12
August 7, 2007 at 16:19:33

I'm glad to hear you solved your problem. I wasn't aware setting the jumper to Master with Slave when it was actually Master by itself would have any affect, or that recent WD drives still had that setting.

Report •

#13
August 7, 2007 at 16:38:31

Tubes, He is running without the jumper at all and that solved the problem. After he sid what he had done then I remembered that is the way my external is also.

Report •

#14
August 9, 2007 at 13:41:55

Well, no jumper = single-drive mode, so saying "without the jumper" or "Master by itself" is basically the same thing in the case of this drive. =\

--Laogeodritt


Report •


Ask Question