sony vaio hard drive not detected

July 3, 2006 at 08:38:48
Specs: xp, centrino /512

I have a sony vaio laptop pcg-z1a - it was working fine then suddenly blue screened with the fault being atapi.sys. It was doing a memory dump and I thought it was frozen so I turned it off. When I turned it back on it said Operating system not found. I inserted the recovery cd but it said hard drive not found. I replaced the hard drive and booted it back up - operating system not found. Recovery process again said hard drive not found.

I went into the BIOS and it said no IDE drive detected - tested this with both the new drive and old drive - same message.

I rechecked all the connections. I can hear the hard drive spinning when I boot up so it has power. I am at a loss as to what to check next. Someone suggested removing the BIOS battery and then put it back in. I have not tried this as I don't know to remove the battery.

Suggestions?

Thanks.



See More: sony vaio hard drive not detected

Report •


#1
July 3, 2006 at 08:56:56

Have you tried to use the Autodect HDrive in the BIOS? If the BIOS still can't pick up a known good HD then you might try downloading and running from a floppy, KILLCMOS. Google for this freeware and unzip to a floppy. Either the BIOS or the HDrive controller may be hosed. I don't see how hardware should get hosed from what you describe. KillCMOS should reset the BIOS to factory settings.

Report •

#2
July 3, 2006 at 08:59:55

i went into the bios and said to Load defaults but it nothing changed. There is no autodetect. And there is no floppy drive as this is one of those light weight travel laptops but could I put this KILLCMOS program on a CD or USB memory stick?

Thanks


Report •

#3
July 3, 2006 at 10:26:15

I think you should go to Sony's tech support. They are the experts.

Do yourself a favor BACKUP!


Report •

Related Solutions

#4
July 3, 2006 at 10:44:27

Go to the below wibsite.
Print a copy of the page.
If you don't understand it.......
Do response 3 by ham30.


http://esupport.sony.com/US/perl/swu-download.pl?mdl=PCGZ1A&upd_id=506&os_id=7


Report •

#5
July 3, 2006 at 16:03:47

I understand the instructions but I have no operating system to run this from. It says to be logged on as administrator but without the hard drive being detected, i can't run this. Unless it can be ran from a USB stick or from a CD....there is no floppy drive.

Thanks for the link.


Report •

#6
July 3, 2006 at 16:41:22

KillCMOS is a very small program. If you have the capablilty of booting to the USB stick, that should work, or the CD.

Report •

#7
July 4, 2006 at 10:23:35

Well I came into work this morning and found another computer on our network that blue screened with the same result - hard drive not found in bios. To fix that one, I had to change the controller and then it was see and booted up again.

Apparently at one of our offsite locations there is an outbreak of some new virus and this may all be related. I was connected to our campus mail server at the time my laptop blue screened. All of this has happened in the past two days so doubt it is a coincidence.

I have tested my hard drive in another computer and the files are all there and accessible. Ran chkdisk, did fixmbr and fixboot but laptop bios still says IDE adapter not found - the hard drive does spin in the laptop so it has power from that same controller cable.

I am thinking that I will need to replace the controller.


Report •


Ask Question