Question about routers

D-link / Di-604
March 24, 2009 at 03:14:39
Specs: N/A
I live in an apartment and the way I hook up to the internest is by pluging the ethernet cord directly to my computer, and entering an ID and password everytime I want to go on-line. After doing so, if I want to use the router, I just remove the ethernet cord from the computer and connect it to the router (I don't use the router for my computer, but for other things). For over a year I've had no problems with that, but now all the sudden the only way I can use the router is by entering that password and ID after connecting the ether net cord to the router and connecting the router to the computer. I now have to use the router with the computer before I can use it with anything else. I sure don't remember changing any settings on the router but is there some sort of setting I can change so that it goes bck to the way it used to be?

See More: Question about routers

Report •


#1
March 24, 2009 at 06:35:46
I have several of the same router, it was my first model, and several other D-Link ones.

Your simplest solution is to just use the router all the time.
Your router has a hardware firewall - even with just default settings, you are much better protected from the bad guys when you connect to the internet through a router than when you connect directly connected to a network adapter .

That was the reason I got a router in the first place, although now I always have two or three computers connected to the router, or up to four when I'm working on other people's computers .
.......

If you haven't changed the router's settings or reset them to defaults in it's configuration, or reset it to defaults externally (there's a tiny hole on the back near the power jack with Reset beside it - a slender pin or a stiff wire can be inserted there and held pressed in for x seconds to reset the settings to defaults) , it can't change any user setting automatically.

I'm assuming you have only one computer you connect to the router.

Have you changed which network adapter you're using on the computer, or are you using a different computer than before but not the same network adapter?

The only way I know of you could have the situation you have is your ISP requires MAC address registration, and you have changed which network adapter you are using.

Some ISPs require you register the MAC address of the network adapter or the router you connect to the high speed modem with in order to connect to their service. The MAC address is a unique identity code many network related devices have that can be detected by software. (The router calls it the MAC address; 2000 and XP call the MAC address the Physical address; 95, 98, 98SE, and probably ME call it the Adapter address.)

My ADSL ISP, Telus, allows up to two MAC addresses to be registered.
Other ISPs may only allow one.
When I run the ISP's installation software that came with my standalone high speed modem, one MAC address is automatically registered on a web site of the ISP's in the background .

Two scenarios........

1. one MAC address has been resistered.
In that case, the MAC address of your network adapter on the computer was CLONED, or typed in manually, in the router's configuration when it was set up. When the router is connected to the modem , the ISP's software can only detect whatever MAC address info the router provides. The router can either provide to the ISPs software it's own MAC address, or one you typed in that's a MAC address of a network adapter you have, or it can copy - CLONE - the MAC address of a single network adapter the router is connected to on the computer when you run the router's configuration.
In that case, whether you connect the modem to the router or the network adapter on the computer, your ISP sees the same MAC address.
E.g. in my case, when I first connected to my ISP I had no router, so the MAC address that was registered was that of the network adapter on my computer. When I later got a router, I CLONED that network adapter's MAC address in the router's configuration.
I can connect any computer to the router and connect to the internet because it has the MAC address of the original network adapter I connected to the ISP with, but I can only connect to the internet when that one network adapter is directly connected to the modem (or one other network adapter that I had registered).

If you changed your network adapter you're using on the computer, or you are using a different computer than before but not the same network adapter, the router would still be able to connect to the internet but not the network adapter on it's own.

2. Two MAC addresses were registered - one for the router, the other for the network adapter, but you have changed which network adapter you are using. In that case you can now only connect to the internet with the router.

........

If you have changed which network adapter you're using on the computer, or if you're using a different computer than before but not the same network adapter, if your situation is like mine, you could
- run the ISP's software installation when the modem is directly connected to the network adapter - that will register the MAC address of the network adapter.
- then run the router's configuration when the router is connected only to that same network adapter and CLONE the MAC address of the computer's network adapter in the router's configuration.
- both the network adapter alone and the router will then be able to connect to the internet.
......

If your situation is not like mine, I need to know the name of your ISP (Internet Service Provider) - e.g. you may have to go to a specific ISP's web site to change the MAC address registration.


Report •

#2
March 25, 2009 at 03:39:28
Thanks for the in depth reply. I haven't switched any equipment so the Network adapter should be the same. I'm not sure what brought about this suddenn change but in any case I'll try the Clone MAC address thing and see if anything happens.

Report •

#3
March 25, 2009 at 06:49:46
Sometimes the ISP will make some changes to their system that may require an update to your router. Look at the link below to determine if there are any firmware updates available for your router.

http://support.dlink.com/emulators/...


Report •

Related Solutions

#4
March 25, 2009 at 07:03:55
"I haven't switched any equipment so the Network adapter should be the same."

In that case DO NOT do JUST this:

"...I'll try the Clone MAC address thing..."

That will result in you NOT being able to get on the internet with either the router or the network adapter, since you can't connect with the network adapter now.

Although, this MIGHT work
"- run the ISP's software installation when the modem is directly connected to the network adapter - that will register the MAC address of the network adapter.
- then run the router's configuration when the router is connected only to that same network adapter and CLONE the MAC address of the computer's network adapter in the router's configuration."
.......

"Sometimes the ISP will make some changes to their system that may require an update to your router. Look at the link below to determine if there are any firmware updates available for your router."

That would be a thing to try if the router connection wasn't working, but that's not your case.
If it ain't broke, don't try to fix it - the router connection is working as it is.
........

Please provide the name of your ISP and I'll see what I can find out.


Report •

#5
March 25, 2009 at 07:16:44
tubes

I have first hand experience of a D-Link router intermittently dropping out and needing to be re-initiated. I contacted D-Link tech support and was told to update the firmware for the reason I described above.

After doing so, the router started functioning fine for a period of time. Eventually I was told by D-Link techs that my ISP had made more changes which would require another firmware update to correct. Unfortunately the router was no longer being supported by D-Link so I had to replace it.

That router was a D-Link 601, which I believe is basically the same as the 604 but without the integrated 4 port hub/switch.


Report •

#6
March 25, 2009 at 08:24:46
OtheHill

It sounds like Sai1 can connect with the router fine. If he couldn't connect reliably with the router that's another matter and what you are suggesting may apply.

I've had to have my ADSL modem upgraded to a newer type, but my DI-604 still works fine for my !SP situation with whatever firmware it came with.


Report •

#7
March 26, 2009 at 01:47:49
I can connect with the network adapter (by network adapter we're talk ing about the coumputer right?). and the router. It's just that all the sudden, for me to connect with the router now, I have to hook it up to my computer first and use it with the computer. Only then can I use the router for other devices. Before, all I had to do was log in with my computer and then all I would have to do is remove the ethernet cord from the computer and connect it to the router. (I said previously that I had to enter the user name and password again with the router connected to the computer but I just found out that's not the case. I just need to actaully use the browser once after I connect the router to the computer. Oddly, If I open another browser however, I have to re-enter the user name and password. Something that isn't required if the ethernet cord is hooked up directly to the computer.) I'm in Japan right now with a service provider called LEO-NET.

Report •

#8
March 26, 2009 at 10:30:50
The network adapter is the networking device that connects to your mboard - it's either built into the mboard, or on a card in a slot, or it's a USB connected device. If it's a"wired" network adapter it has a port you plug a networking cable into.
If it's a wireless network adapter it has an antenna, either external to it (on a card in a mboard slot) or internally (a USB connected wireless adapter).

"I'm in Japan right now with a service provider called LEO-NET."

The web site

http://www.leo-net.jp

apparently is in Japanese and does not have any apparent English interface you can select, so there's no way I can look up anything in English there.
If you can't read Japanese either, niether can you.
.......

Were you using a different ISP before, or always the same one?

If you were using a different ISP before, they don't necessarily have the same requirements.


Report •

#9
March 27, 2009 at 01:37:24
Same ISP as before. I could just take your advise about always using the router though. I was simply condsiering myself to be saving a liitle electricity.

Report •

#10
March 27, 2009 at 06:47:32
A router is your first line of defense against outside intrusion.

Report •

#11
March 27, 2009 at 08:30:50
"A router is your first line of defense against outside intrusion."

"Your router has a hardware firewall - even with just default settings, you are much better protected from the bad guys when you connect to the internet through a router than when you connect directly connected to a network adapter ."


Report •

#12
March 27, 2009 at 22:59:59
New discovery. Even using the router all time doesn't solve the problem. I still have to connect the ethernet cord directly to the computer first and log on that way. Then after logging on, I have to connect the ethernet cord to the router and the router to the computer. If I try connecting via the router first and put in the user ID and password, no matter what site I go to, it says connection refused, or can't find the server (depending on the browser).
Oddly, this same things happens if simpy cut the power to the router while I'm using it and turn it right back on. I won't be able to use the router again until I connect the etherner cord directly to the computer, use a browser, and then plug the cord back into the router.
What does this mean?

Report •

#13
March 28, 2009 at 10:19:21
There are 5 network ports on the DI-604
There are two types of network port connections on the DI-604.
One is on one end by itself and is labelled WAN.
The other 4 are beside each other and are labelled 1, 2, 3, 4 - those are the LAN (Local Area Network) ports.

When you use the router, the high speed modem must be plugged into the WAN port.
It doesn't matter to the DI-604 whether the network cables are wired straight through or are crosslinked.

When you log onto the internet with the network cable directly connected to the high speed modem and the network adapter on the computer, then plug the cables into the router, if you plug in one of the cables into the WAN port - it's supposed to be the one for the high speed modem - and the other one into one of the LAN ports, 1, 2, 3, or 4, then if the configuration of the router is not correct, you will be unable to connect to the internet.
.......

If you need some instructions for how to possibly set up the DI-604's configuration correctly, so that it will work with both the router and the network adapter AND you will be protected from the bad guys by the hardware firewall in the router, I need to know which country you bought the DI-604 in (if it's Japan, or some other country I can't read the language of, I can't help you - you will have to connect both cables to the LAN ports in the router).

You can enter the password you need to use in the DI-604's configuration. I don't need to enter a password, but in theory, when that is done correctly, when you connect to the internet through the router, with the modem connected to WAN and the network adapter connected to 1, 2, 3, or 4, then you probably will not need to type in the password.


Report •

#14
March 28, 2009 at 14:28:44
"You can enter the password you need to use in the DI-604's configuration. I don't need to enter a password, but in theory, when that is done correctly, when you connect to the internet through the router, with the modem connected to WAN and the network adapter connected to 1, 2, 3, or 4, then you probably will not need to type in the password."

That's worth a try. The router was bought in America. Although, the only place in the configuration I see that you can enter a username and password, is in the tools tab but that's just the password to changes the router settings itself.


Report •

#15
March 28, 2009 at 15:34:44
tubes, are you sure about the ports on that router. I believe there is one port that can be used as an uplink to a hub or switch to expand the number of users. That router should be able to configure 255 users.

Also, the mere fact you are using a router shields the computers from the outside world. The only thing someone on the outside can normally see is the address of the router.


Report •

#16
March 29, 2009 at 10:05:28
OtheHill

Yes I'm sure - I have one on hand. I read somewhere you can use any LAN port as an uplink port by using a crosslinked network cable between it and the LAN port you connect it to. In the case of this model, either a straight through or a cross linked cable works for that purpose because it detects the type of connection needed on it's end automatically and changes connections internally if needed, but with older routers you might be required to use a cross linked cable. A place I know of has one of these hooked up to a hub with a straight through cable.
......

Sai1
"The router was bought in America."

I assume you mean in the US.

An emulator allows you to see online the same things you see in your router's configuration.
Trying the emulator does not actually access your router's configuration.

Go here to look at the emulator for your model:
http://support.dlink.ca/faq/view.as...

Look at the label on the bottom of the DI-604 to see which Rev. it is.
choose the DI-604 emulator choice for that Rev.

"Enter Network Password" window appears.

User Name: default is admin
Password: default is no password - don't type anything in that box

Click on OK

Click on WAN

That page is set to a Dynamic connection by default.
That's probably not what you're using, and that's the only one that may need for you to CLONE the MAC address of the Network adapter on your computer.

Since you must use a password, your LEO-NET ISP probably uses either

PPoE, or Others - PPTP

I searched with:
PPoE "leo-net.jp"
and
PPTP "leo-net.jp"

The "hits" are in Japanese - It appears it's using PPoE

Try setting up PPoE
Click on Help at the bottom of the page if you need to

.......

Here's how to access and actually change the router's configuration:

FAQ from D-Link

How can I configure my DI series router to work with a DSL (PPPoE) connection?
http://support.dlink.ca/faq/view.as...

NOTE: Re-setting the router to defaults, and upgrading the firmware, is usually something you DO NOT need to do.
.......

I recommend you copy down all settings in the router's configuration before you change any settings, so that you can change them back to the way they were if you need to.

There is a pretty good manual on the CD that came with the router if you have that or if you have copied that to your computer, or you can probably download it from the D-Link site (DI-604 is a discontinued model - download the one for your Rev.), if you need more info.


Report •

#17
March 29, 2009 at 10:13:26
Here is a link for a manual.

http://www.dlink-me.com/ftp/broadba...


Report •

#18
March 29, 2009 at 10:17:44
Here is a link for a manual.

http://www.dlink-me.com/ftp/broadba...


Report •

#19
March 29, 2009 at 10:24:27
Here is another link that may prove useful.

http://www.fixya.com/support/p27894...


Report •

#20
March 30, 2009 at 02:09:09
Actually, I am using Dynamic ISP. None of the other settings work. This router is being really fickle though. This time I logged on via the router first with no problem...

Report •

#21
March 30, 2009 at 06:04:53
Try updating the firmware.

Report •

#22
March 30, 2009 at 08:24:40
There are two types of Dynamic connection in the DI-604's configuration - the default one, which may require you clone the MAC address of your network adapter, and the default PPoE one, which has no MAC address requirement. The default one does not require you enter a password - the PPoE one does - you probably have a Dynamic PPoE connection. If you enter the password you use there and the right other entries, if you use the router you may not need to enter the password anymore.

"This router is being really fickle though. This time I logged on via the router first with no problem..."

In my experience connection problems are not caused by a problem with the router - they're a lot more likely caused by a problem with the the high speed modem's connection.

If your connection is DSL or ADSL, try re-booting the high speed modem when you have problems connecting.
I have an ADSL connection and I have to do that frequently ( I connect to an overhead telephone line on poles installed in 1959) .
If the modem has a switch, turn it off, turn it back on. If it doesn't have a switch, uplug the power adapter connector at the modem, plug it back in. Wait a bit until the leds on the modem indicate the DSL or ADSL connection is working, then you should have a good connection.

DSL and ADSL connections are directly affected by telephone line noise problems.

Universal DSL/ADSL stuff.
See the latter part of Response 1 here:
http://www.computing.net/answers/ha...


Report •


Ask Question