power supplies blowing within an ho

March 3, 2009 at 09:59:07
Specs: Windows Vista, AMD 64 X2 6000, 2x 1GB DDR2 800MHz OCZ Gold XTC
Running a custom built machine for about over a year. Other components include
Sapphire ATI X1950XT 256MB GDDR3 VIVO dual DVI PCI-E Graphics Card
Seagate ST3320620AS 320GB Hard Drive SATAII 7200RPM 16MB Cache - OEMMSI K9N4 Ultra-F SKT AM2 DDR2 5.1 Channel audio ATX
Sumvision 600W 20+4pin SATA 2x 80mm Fan PSU (orignial PSU).

The problem happened over a week ago when my PSU went pop when playing eve-online. Went to a repair shop they said it was the PSU gave me a new one. Computer ran fine when on the internet . Went back on eve and the 650W PSU cut out. Went back to the shop and confirmed its demise. They gave me an identical PSU, same situation. Went back and they asked about surge protection and i didn't have any.
Originally, i did use surge protection but a few months ago when i turned my pc off it shorted out the house electrics. This happened more frequently and i found that when i didn't use the surge protector it worked fine and i didn't trip the house electrics. So i assumed the surge protector was dead and never got round to getting a new one.
I got the new surge protector and they gave me a new PSU. Again ran fine up until i played eve and it once again died within 10 minutes. Should i try to replace parts or just give up and get a new pc?

See More: power supplies blowing within an ho

Report •

March 3, 2009 at 10:35:44
"Should i try to replace parts or just give up and get a new pc?"

How about investing in a good power supply instead? You should expect to pay about $75 US for a decent quality name brand 650W PSU. How much did the Sumvision 600W cost, $25? When it comes to PSUs, you generally get what you pay for. Here's a clip from a review of the Sumvision 500W:

"... Once we increased the load to 75 per cent, the PSU ran for five seconds before exploding spectacularly. The Power X is very cheap but can't even deliver 375W, let alone 500W. One to avoid."

Maybe this will help you take make a better decision:


Report •

March 3, 2009 at 11:46:19
Yep, there don't seem to be any specs on that PSU but it is cheap.

One thing you should probably check is your house voltage. If you have had surge protectors go out there may be a problem there.

You are setting the voltage selector switch on the back to the correct voltage? If you use 230V and set to 115V you will surely fry the hardware.

Report •

March 4, 2009 at 08:23:02
So there isn't the possibility that the motherboard or graphic card is shot then?

Have made sure the voltage setting is 230V as the UK powergrid uses ~230V.

Report •

Related Solutions

March 4, 2009 at 09:38:46
Sure there is that possibility. Whenever a PSU goes out there is a possibility the motherboard and beyond can be damaged. Has anything been damaged? I would guess you were lucky. The system probably wouldn't run if damaged.

Look at the socket where the power connector plugs into the motherboard for any discoloration or melting. Also check the vidoe card and slot it resides in for the same.

My guess is those power supplies are just not up to the task. Without any specs on them that is just a guess. Some manufacturers have been known to fudge the numbers too.

Whenever I find hardware that doesn't have accompanying specs it makes me wonder what the maker is trying to conceal.

Report •

March 5, 2009 at 06:55:14
Thanks for the help. Im off to but a decent power supply now!

Report •

Ask Question