power problems

Toshiba / Satellite m305
June 6, 2010 at 15:54:12
Specs: Windows XP
i have a toshiba satellite m305, and recently it
just died on me. but it has some akward
symptoms. it wouldnt work at first i.e. no lights
would come on when it was plugged in, it
appeared to be dead. then i decided a few
months later before i threw it away to give it
one more shot, and it started working... for
about 5 minutes then died again. after
attempting my own repair it worked for a good
3 hours then died one last time. this makes
me wonder what could be wrong. the lights
only come on when plugged in. but
immediately after pushing the power button it
dies out. if i unplug it and plug it back in or
take the battery out and put it back in the
lights re-appear. then the cycle repeats itself.
any ideas?

See More: power problems

Report •

June 6, 2010 at 16:01:50
One like this?


What did you do to get it to temporarily run from 5 minutes to 3 hours?


Report •

June 6, 2010 at 16:03:57
Pull the battery and plug power supply only and give it a try.
Maybe the battery has a short-circuit

The original poster should always write the last response !!!
Let us know, if the problem is solved !!!

Report •

June 6, 2010 at 21:12:54
yes that is the computer. and all i really did to it when it started
working was wiggled wires and cleaned it out by blowing off the
fan (it was pretty dusty) and made sure all connections were
solid. i have torn it apart again and repeated but i cannot get it to
turn on again. and i have tried to only use the power supply, the
only time the lights come on is when the power supply is
plugged in and the battery is in. it wont work with just one or the
other. any different ideas?

Report •

Related Solutions

Ask Question