PC not working if GRAPHIC card installed

November 1, 2011 at 03:08:32
Specs: Windows XP

If I install graphic card on motherboard's PCI slot PC is not working no fans, no HDD, no beeps, no boot, nothing. But I can see working lights on Motherboard.

If I remove Graphic card everything is working fine.

Please help me ..

SYSTEM Config:
Mother board: xfx Nvidia 680 SLI LT
Memory: 4GB 1GB in each slot
Video/Graphic card: Nvidia Geforce 7900GS 512MB 256bit.

See More: PC not working if GRAPHIC card installed

Report •

November 1, 2011 at 04:07:50
PCI and PCIe are two different slots.
Are u sure the video card is working? I have seen some bad v-cards but the fans starts when push power button.

You know the real meaning of peace only if you have been through the war.

Report •

November 1, 2011 at 05:50:24
Your power supply may be too weak to run the card. That card is not all that demanding but you didn't provide any information on your power supply. That card by itself will draw a maximum of 82 watts from the 12V rail, which equates to about 7A. Depending on your entire system, you probably need a PSU with at least 22/23A on the +12V rail. If you need to replace the PSU post all system specs for further help with sizing the PSU.

Also possible you are not fully seating the card or not connecting any additional power connectors.

Report •

November 1, 2011 at 08:02:34
To sum it up:

- the card is PCI-express, not PCI
- it's an older power-hungry card
- it requires additional power connectors plugged into it or it will not work
- therefore it needs a decent power supply

It's performance is comparable to an nvidia GT 220 or Radeon HD 6450, both of which require significantly less power & are considered entry-level cards.


Report •

Related Solutions

Ask Question