Solved PC lags badly after plugging in thumb drive?

January 1, 2013 at 09:40:37
Specs: Windows 7

I am using a Cruzer Edge 8GB thumb drive, it worked fine all the while. Today, I plugged it into my desktop and found that it wasn't detected. I went to disk management, wasn't there either. After around 5 minutes, a G drive showed up on "My Computer" and my explorer started lagging really badly. When I create new folders, they don't show up, I need to move out of the directory and re-open it to show the changes I have made. When I removed the thumb drive, my PC went back to normal. I've tried my thumb drive on other PCs, and it worked fine. I've also tried other usb ports on my desktop, doesn't work either. However, my desktop is able to run my external hard drive and other usb devices. Lastly, I tried other thumb drives that are working, but they don't run on my desktop either.

What might be the issue here? How do I solve it?

See More: PC lags badly after plugging in thumb drive?

Report •

January 1, 2013 at 10:50:59
✔ Best Answer
You supplied zero info about your computer but you might wanna try scanning for malware/viruses.

Report •

January 1, 2013 at 14:47:42
In addition to the malware scan update all USB and chipset drivers. You also can do a file system check on the thumb drive to be sure.

Report •

January 2, 2013 at 01:06:18
Thanks! I did a virus scan and found several malwares in my music folder. Everything returned to normal after I removed the malwares.

Report •

Related Solutions

Ask Question