No video on my screen

August 1, 2013 at 11:24:20
Specs: Windows 8
I put together my computer With a P8Z68 Deluxe motherboard and the computer starts up with the power button on the MOBO but i cant start it with the power button on the case. When the power is on there is no picture on the monitor and the Graphic card is about one year old. I bought it to replace one and pulled it out of my old build and put it in my new build. I have looked at everything and i cant seem to find the problem Could someone please help me.

message edited by Stevee2012

See More: No video on my screen

Report •

August 1, 2013 at 12:07:01
Please list your complete system specs in deatil.

Report •

August 1, 2013 at 13:01:55
EVGA 01G-P3-N988-TR GeForce 9800 GT Video Card - 1024MB DDR3, PCI Express 2.0, DVI, HDMI, VGA

Corsair CMX6GX3M3A1333C8 XMS3 Triple Channel 6144MB PC10666 DDR3 Memory - Tri Channel, 1333MHz, 6144MB (3 x 2048MB), 7-8-7-20

ASUS P8Z68 Deluxe Intel Z68 Motherboard - ATX, Socket H2 (LGA1155), Intel Z68 Express, 2200MHz DDR3 (O.C.), SATA 6.0 Gb/s, 8-CH Audio, Dual Gigabit LAN, USB 3.0, CrossFireX/SLI Ready, Bluetooth

Intel Pentium G2030 Processor

Report •

August 1, 2013 at 13:21:20
What about the power supply?

Report •

Related Solutions

August 1, 2013 at 13:23:20
the power supply is 550 watt

Report •

August 3, 2013 at 05:49:33
"the power supply is 550 watt"

You posted everthing else in detail, why not the PSU? Just stating the wattage tells us nothing. What is the make/model of the unit & the amperage specs on the +3.3v, +5v, & +12v rails?

Did you bench test all the hardware before installing it in the case?

message edited by riider

Report •

Ask Question