No mouse works ps/2 or usb

Micro soft / Intellipoint
August 4, 2009 at 18:22:05
Specs: Windows XP
I can't get my mouse to work on xp in either the ps/2 port or the usb ports. It was working fine. I uninstalled the ps/2 (it gives device error 10) rebooted, and it still shows up in device manager with the exclamation point. I plugged in a usb optical mouse and it was detected, but still doesn't work. I've updated all drivers, and can't find a usb option in the bios. keyboard works fine

See More: No mouse works ps/2 or usb

Report •

August 4, 2009 at 18:44:45
When you say that you uninstalled the ps/2-do you mean you unplugged it while the compuetr was on ? If that is the case, I would try shutting down the computer, unplugging the USB mouse, and then plug in the ps/2. Restart and see what happens.

Report •

August 4, 2009 at 18:57:25

Verify the PS/2 mouse was in the green port and not the purple.

Are you using an adapter to connect the mouse?

Report •

August 4, 2009 at 19:11:06
I unplugged the ps/2 mouse, restarted, and plugged it back in and nothing. then i went into device manager and removed it, restarted - attempted to get plug and play to recoginze it. device manager still has it at error 10.
when i plug in a usb mouse, it detects it but it won't work.

Report •

Related Solutions

August 4, 2009 at 19:24:02
You didn't answer if you are using an adapter on either mouse.

If you know how to maneuver in Windows using the keyboard then download Ccleaner slim. Run both the cleaner and registry modules. Get it at the link below.

Report •

August 4, 2009 at 19:30:44
PS/2 connected devices are NOT hot-pluggable like some USB devices are (you can plug in a USB device in most cases at any time, but some you're not supposed to unplug until you have stopped accessing it) . You're only supposed to plug them in or unplug them when the computer is NOT running, otherwise you may damage the device or the PS/2 circuits. If you have unplugged the device while the computer is running, it almost always will NOT work when plugged in again until AFTER you have rebooted, so there's usually no point in unplugging it while the computer is running in any case.

"I plugged in a usb optical mouse and it was detected, but still doesn't work."

USB devices may not work correctly when they're connected to certain USB ports, e.g. ports in a hub or on the front of a desktop case.

See response 3 in this:

When you have previously been using a PS/2 mouse, the first time you connect a USB mouse a mouse cursor shows up on the screen, while booting, or in Windows, but it doesn't work (won't move) unless or until the Windows desktop has fully loaded and then the USB mouse is detected and drivers have been loaded for it.
If you need to Logon and/or enter a password while booting, use the Tab key to toggle which choice is selected, the Enter key to execute the choice.
If you are using a simple adapter to adapt the connector on the end of the mouse's (or keyboard's) cord to another type of port, that will not work unless the mouse (or keyboard) is a"combo" one that is designed to be used with, and has the circuits wired up for, both types of ports. A "combo" mouse (or keyboard) comes with the proper simple adapter when new. The simple adapter for a mouse, often green, may NOT work with a keyboard, and the simple adapter for a keryboard, often purple, may NOT work with a mouse, because the necessary circuits in the adapter may not be wired up.

Corded mice and keyboards commonly develop broken wires inside the cord, usually right where they enter the device, after they have been used a lot, or at any time if the cord has been yanked on - the mouse of keyboard MAY work when the cord is in certain positions, not work when it isi n other positions, or when you wiggle the cord, near the device. Try another mouse or keyboard.

If your power supply is not putting out enough of what is supposed to be +5v, or is putting out no +5v at all, your USB ports, PS/2 ports, serial ports, floppy drive if you have one, and optical drives will not work properly or will not work at all.

Failing power supplies are common and can cause your symptoms.
Check your PS.
See response 4 in this:

If you have reloaded Windows....

Whenever you load Windows from a regular Windows CD (or DVD) from scratch, after Setup is finished you must load the drivers for the mboard, particularly the main chipset drivers, in order for Windows to have the proper drivers for and information about your mboard hardware, including it's AGP or PCI-E, ACPI, USB 2.0 if it has it, and hard drive controller support. If you have a generic system and have the CD that came with the mboard, all the necessary drivers are on it. If you load drivers from the web, brand name system builders and mboard makers often DO NOT have the main chipset drivers listed in the downloads for your model - in that case you must go to the maker of the main chipset's web site, get the drivers, and load them.

The USB ports should work even before you load main chipset drivers, but the PS/2 ports may not, for a laptop.

Report •

August 4, 2009 at 19:48:11

"Verify the PS/2 mouse was in the purple port and not the green."

That's the opposite to what it should be.

Although, for a small number of desktop mboards, a mouse or keyboard will work in either port.

If a laptop has a single PS/2 port, usually both of either a mouse or a keyboard will work with it, or both can be connected and work at the same time by means of a standard Y cord made for that purpose.

The PS/2 mouse support must be enabled in the bios Setup - it is by default but it can usually be disabled.
The USB controller(s) must be enabled in the bios Setup - it is (they are) by default but it (they) can be disabled.

Report •

August 5, 2009 at 00:44:32
But I think you might first need to try turn off the computer install the PS/2 mouse properly. Then start up the computer.

Want A Weekly Update on Latest System Security Problem

Report •

August 5, 2009 at 06:15:53
The mouse is plugged into the green port, and I have swapped out three different ps/2 mice - none work.
The cursor appears in windows, but does not move.
I can operate using the keyboard (but for example, cannot start avast this way).
neither ps/2 or usb are options to enable/disable in the bios. this is a generic desktop (compaq deskpro en).

I did reload windows - so I am now thinking it's a chipset driver issue.

can anyone help me figure out where to download the chipset drivers? should i load siw to get motherboard info (since the keyboard/mouse are combo)?

also - re usb - I used the port on the back, which recognized the usb mouse but it didn't work...i plugged my external drive into this port as well, with no recognition. i'd like to get this port working also.

Report •

August 5, 2009 at 06:48:26
Does your keyboard work OK? You can blow a PS/2 port by hot swapping but the USB should still work.

What type of disk did you use to reload WinXP and did you reformat or go over the top? If you used the Compaq restore disks you shouldn't need any other drivers.

Post your Compaq model so we can provide a link to all the drivers.

Do you have a card reader in that computer? Remove all unnecessary hardware. Especially any USB stuff.

Have you tried booting into Safe Mode (F8) to see if things are different there?

Report •

August 5, 2009 at 07:15:52
Keyboard works fine. I reloaded over the top with xp cd. i don't have the restore disks.
it's a deskpro en, but i'm am going to post siw output shortly.
i have no card reader. no usb hardware is installed (doesn't work anyway).
all scans come up clean (malwarebytes, spybot, avast - all installed and run separately). running ccleaner next. avast did report a memory virus on first boot scan, but i fixed it, and reran with no infection.

Report •

August 5, 2009 at 07:46:25
You do need to install the motherboard chipset drivers then. The Compaq model is necessary. EN isn't enough to go on . How about a serial number then?

Go to the link below for help with identifying your model.

Report •

August 5, 2009 at 12:41:14
I downloaded chipset drivers and it says the current operating system supports inf, no update needed...

Report •

August 5, 2009 at 14:09:24
Go to device manager and see if all the hardware is working properly or if there are any yellow Exclamation marks.

Report •

August 5, 2009 at 14:49:24
Yellow exclamation mark on the PS/2 compatible mouse with device error 10.

Report •

August 5, 2009 at 15:13:24
You MAY have damaged the PS/2 port. Remove the listing for the PS/2 mouse as well as ANY other mice in Device manager. Shut down the computer and connect ONLY the PS/2 mouse and restart the computer.

If the mouse still doesn't work then shut down and disconnect the PS/2 mouse and connect a USB mouse and reboot.

There are many possible reasons for the code 10 error. Registry errors is one possible cause.

Download an install Ccleaner Slim from the link below and run BOTH the cleaner and the registry modules.

Report •

August 6, 2009 at 01:41:32
Are you sure that is the usb mouse si also not working? To the looks of it the problem is in the system it self. Now the try to see if even in safe mode that the problem is still happening.

Want A Weekly Update on Latest System Security Problem

Report •

September 27, 2009 at 13:32:26
hi!His that thread still alive!
Because i got the same problem.
Does the tread stop at Response Number 16?
I don't see the follow up


Report •

September 27, 2009 at 13:45:04
dan, this thread is inactive. Start your own thread here in the hardware forum.

Report •

Ask Question