No Display (Replaced MB and PSU)

sosadmycomputerbroke February 12, 2009 at 16:05:57
Specs: Windows XP
I've recently ordered the 4870 x2 to replace my older video card the 7800gt.

When I installed the new card for the first time no display showed up after I turned on the computer. I realized that my psu was too small, rated at 600w(OCZ stealthxtreme). So I bought a new one that was rated at 750w (Corsair Tx750).

After replacing the psu and trying again. No display showed up again. I tried installing my old video card the 7800gt to see whether I had fried the new video card because of not giving it enough juice. No display again. I then figured that I must have fried the pci-e slot on the motherboard. So I RMA'd it with newegg and got a replacement of the same board. (DFI LanpartyJR p45-t2RS)

I got the new motherboard and tried both video cards again. Still no display. I also tested the video cards on my friends computer and they're still functional. I'm all out of ideas. I've already replaced my PSU and my motherboard, I don't know what else it could be.

It's definitely not the monitors because I've already tested both too with my laptop. They both work.

Please help.


extremely frustrated computer user.

These are the other specs FIY:

C2D E8500
4x2gig DDR2 OCZ SLI-Ready RAM
2x640 WD Drives
DFI Lanparty JR P45-T2RS MB
750w Corsair TX
Xigmatek s-1283 heatsink w/backplate

See More: No Display (Replaced MB and PSU)

Report •

February 12, 2009 at 17:10:07
ATX mboards are always powered in some places, including some contacts in the PCI-E and ram slots, as long as the ATX power supply is plugged into the mboard and the PS is receiving live AC. You are ALWAYS supposed to unplug the computer, or switch off the AC to the computer, whenever you make any changes to connections or components inside the case, especially when you unplug or plug in card in slots. Did you do that, every time? If you didn't, you may have damaged something, including the video card(s), or the PCI-16 slots or their circuits, or the PS. E.g. I had one PS that fried merely because I had forgotten to unplug it when I plugged in a hard drive power connector!

Did you have the extra power connection from the power supply to the mboard other than the main one, and the extra power connections from the PS to each video card plugged in when you were trying to boot the mboard? If you didn't, of course, the mboard won't boot properly!

Did you change which ram you had in the first mboard since it last worked properly?
If you DID,
Ram that works in another mboard , or any ram you buy or have lying around, may not work properly, or sometimes, not at all - even if it physically fits and is the right overall type (e.g. SDram, DDR, DDR2, etc.; PCxxxx, xxx mhz) for your mboard. In the worst cases of incompatibilty your mboard WILL NOT BOOT with it installed, and the mboard may not even beep - the ram has to be compatible with the mboard and it's chipset.

See response 5 in this for some info about ram compatibilty, and some places where you can find out what will work in your mboard for sure:
Correction to that:

Once you know which module ID strings work in your mboard, you can get them from anywhere you like that has ram with those ID strings.

If you have brand name ram, it is usually easy to look up whether it's ID string is in a list of compatible modules found by using your mboard or brand name system model number.
If the ram is generic, that may be difficult or impossible.

What ram are you using in the new mboard? The same ram as you used before? If you changed which ram you had installed in the original mboard, it may not be compatible with the new mboard either!

It is easy to test for incompatible ram that has caused your mboard to fail to boot.

Make sure you have a speaker or speakers connected to the mboard so you can hear mboard beeps (see your mboard manual).
Remove the AC power to the case/power supply.
Remove all the ram.
Restore AC power.
Try to boot.
If nothing else is wrong, you will hear a pattern of beeps that indicate no ram is installed, or a ram problem.
E.g. for an Award bios or a bios based on one, that's often a beep of about a half second, silence for a half second, a beep of about a half second, silence for a half second, continuously.

The size of your first power supply was probably at or a little over the minimum required to support a system with two 4870's - see the specs for the cards you bought on the manufacturer's web site - the minimum capacity and maybe the minumum current it must supply at 12?v is stated in the specs somewhere, often under system requirements, and often there is also similar specsfor two cards, or a card with two 4870's (it's not twice asmuch asfor one video chipset. If you don't see that on your card makers's web site, look on other web sites that have cards with the 4870 chipset - the specs are about the same for all cards with the same chipset.

Even if your first PS were a little undersized, that would not cause the cards to not work at all, or ruin the PS so the the original card would not work. Typically an underpowered PS will still work intitially and for quite a while until the overloading it experiences has damaged it.

Do these mboards have an AMD chipset?? If they don't, they cannot support you connecting the two 4870's with a Crossfire cable connection to each other - the mboard does not support Crossfire - the two cards will work - you just can't use Crossfire mode.

If you have access to another working desktop computer, try both PSs to rule out them being damaged.

Report •

February 12, 2009 at 17:44:53
The only explanation is that you did something wrong when you installed the new card. Did you have BOTH the 6-pin AND 8-pin aux power plugs connected to the card? When you realized the new card didn't work, did you immediately put the 7800GT back in to test it?

Your 600W PSU should have been adequate provided you had the +12v load balanced correctly. The Corsair unit doesn't require any balancing because it has a single +12v rail. Regardless, the PSU most likely isn't/wasn't the problem.

This isn't really related but I see you have 8GB RAM...are you running a 64-bit version of Windows? If not, take 4GB out, it's not being used.

Report •

Related Solutions

Ask Question