Articles

No boot device found

dell/inspiron 531
September 5, 2008 at 08:48:08
Specs: vista home sp1, amd 64/4gb

well here it is, i rebooted my computer this morning after realizing it had been 2 or 3 days since a reboot. so it rebooted fine then came up to this black screen with this message:

No Boot Device Available
Sata 0: Installed
Sata 1: Installed
Sata 2: None
Sata 3: None

I have not installed anything new, didnt change any bios settings from what it originally came with. The only thing i changed in the comp since i bought it was bought 2gb more of the exact same DDR2 memory and a new geforce 8500gt vid card. but that was about 6 months ago and it was working perfect until this morning.

So then i went into bios and on the first screen it shows you all of the devices that should be detected... only problem is that my hdd isnt detected. my dvd drive is detected fine.

I searched around for awhile this morning but ran out of time and really didnt find anything about my same problem (or im just dumb and couldnt find the right stuff). so i ended up here and am hoping to get some kind of help lol. thank you!!!


See More: No boot device found

Report •


#1
September 5, 2008 at 08:59:21

forgot to post this too, im not exactly sure of all the specs on my comp, as i am not too computer savy :D but this is what i know for sure:

Dell Inspiron 531
Amd Athlon 64 Dual-Core 4400+
Windows Vista Home Basic SP1
4GB NECC Dual Channel DDR2 667MHz SDRAM
Samsung HD501LJ 500GB SATA II 3.0Gb/s HDD
16x DVD+/-RW Sata Drive
Integrated 7.1 Channel (Audio) Capable

Thats all i know for now.


Report •

#2
September 5, 2008 at 09:00:36

And a pretty nifty Nvidia GeForce 8500 GT PCIe 512MB

Report •

#3
September 5, 2008 at 12:03:33

Did you try unplugging the computer, then re-seating the sata cable on you HDD and where it connects to the motherboard, then plugging the computer back in and boot?

Report •

Related Solutions

#4
September 5, 2008 at 13:07:02

You showed that the computer reads a Sata 0 and a Sata 1 as installed (detected?), and then wrote that the DVD drive is detected, but not your HDD. If the DVD drive is either Sata 0 or Sata 1, what is the other Sata device the computer reads as installed? Is the HDD supposed to be Sata 2 or Sata 3?

Report •

#5
September 5, 2008 at 17:16:05

JRComp: No i did not try unplugging the tower and plugging it back in, i will try it now and let you know.

Pyrolitic: ok it reads that sata 0 and 1 are installed, and sata 0 should be the hdd and sata 1 is the dvdrom drive. This is how it was setup when i originally bought the pc.


Report •

#6
September 5, 2008 at 17:19:07

JRComp: ok i just unplugged every cable from the tower and plugged them all back in and still the same screen. it kinda looks like its lagging up on the boot part of it, then it goes to that black screen telling me no boot device available.

Report •

#7
September 5, 2008 at 19:00:03

The lagging on the boot part is probably the firmware (BIOS) attempting to read a boot sector and something is wrong. The computer BIOS is finding the HDD (Sata 0) installed, it is just not able to boot it. I have no experience with Vista SP1, so I don't know what kind of disk diagnostics or repair tools you might have available. If you have (or can get a hold of) a bootable CD-ROM with a OS and some tools that you know how to use, then you could boot your computer from the DVDrom drive and see what you can find out about Sata 0. If nothing else, just something that is capable of reading the file system on your HDD so you can see if it is still working, if you can read files on it. It could just be some kind of boot sector corruption and can possible be fixed with the right software tool. If your computer came with some kind of bootable CD with Vista, there may be some kind of repair tools available on that disk. It is also possible, but rare, that there is some kind of failure with the Sata hardware on the motherboard. Might check with Dell to see if there are any reports of problems with your model. Do you still have any warranty options?

Report •

#8
September 5, 2008 at 19:04:04

thanks alot guys for your help but i got it fixed :D. with a little patience along with 150 bucks i got it fixed and back up and running. At first i just stopped by staples on my way home and picked up a new sata cable. Tried it with the old hdd and still the same problem. So after debating for 10 minutes i decided... Screw it ill go buy a new hdd. so i picked up a maxtor 500gb sata hdd and now its working perfectly fine, if not... better and faster!!! Woohoo...

Report •


Ask Question