New build no boot

Gigabyte Ga-ex58-ud5 motherboard
November 27, 2009 at 06:49:32
Specs: non
Help needed with a new build.
Corsair HX850
Gigabyte EX58-UD5

The machine would not boot up. When putting power on the machine you can hear a clicking noise coming from the PSU and nothing else happens. No Led or Fans. Not the onboard fan controling unit gives live.

What to do now? I Tryed to remove every drive.. ect. And now only CPU, CPU fan, 3x2g DDR3 Ram and a systemfan are connected but no responce to case power and boardpower buttons,..

Can you help?

See More: New build no boot

Report •

November 27, 2009 at 07:24:26
Remove everything out from the case and benchtest. All u need is cpu,cpu fan(heatsink),board,psu,vga card,ram 1stick,monitor,keyboard and mouse.

Report •

November 27, 2009 at 07:28:55
I did try to do this in the pc itself. no responce

Report •

November 27, 2009 at 07:31:32
Never assemble hardware in a case without benchtesting it 1st.

How to Bench Test Your System

Report •

Related Solutions

November 27, 2009 at 07:54:01
try another power supply i think yours is bad


Report •

November 27, 2009 at 08:18:39
I did test the system and it worked!??

I will try now to but the system back in the pc

Inside the case the system does not work any more same configurations >>>

Report •

November 27, 2009 at 08:50:43
The most common error is having the metal standoffs in locations other than under screw holes.

If you have a case that has raised bosses instead of standoffs then you need to place insulating washers at every place the board touches the case.

Report •

Ask Question