Articles

Solved New build, graphic card issue, not displaying.

December 26, 2012 at 11:49:19
Specs: Win 7 32, 4

Here is the config.

i5 3570
Intel DH77KC (DVI HDMI and display port)
corsair vengeance 16GB 1600
cooler master thunder 500W
1 TB harddisk
and an OCZ agility 120 gb.

the card is

http://xfxforce.com/en-us/Products/...

I have got a Samsung s22b370 monitor (vga and HDMI)

I am not getting any display out from graphic card.

The onboard works just fine with HDMI cable and with DVI to vga adapter.

but its not working with same DVI to vga adapter or with the DVI to hdmi adapter that came with the graphic card package from XFX.

If I put that card in and power the card, no display will work. If I remove the card or remove the power cable from the card, then the onboard will work.

The card gets heat up and the fan will run if powered..

Could this be a faulty card?

Yeah I tried with my old 8500gt, runs fine.. and I cannot put this card on another machine as I don't have a 6pin pcie connector on other machine..

So what it could be?


See More: New build, graphic card issue, not displaying.

Report •


#1
December 26, 2012 at 12:21:18
✔ Best Answer

If a different card works in the slot without having to change BIOS settings then that limits the possibilities to two.
1. the card is not compatible.
2. It is DOA.

Goin' Fishin' (Some day)


Report •

#2
December 26, 2012 at 14:26:39

Sometimes the video card refuse to display when adapter is used, try the DVI monitor if u have one.
I cannot put this card on another machine as I don't have a 6pin pcie connector on other machine..
How about using Cooler master PSU to test the card in another working machine?
Note that PCIe 2.1 v-cards will have hard time working in older PCIe 1.0a/1.1 slot.

You know the real meaning of peace only if you have been through the war.


Report •

#3
December 27, 2012 at 01:27:04

I would advise you test this card on another PC and if it works then the graphics card is higher than the PC spec.


Thanks.


Report •

Related Solutions

#4
May 2, 2013 at 22:30:04

I got that card replaced.

Report •


Ask Question