Netgear pc card wont install hardware drivers

Netgear Netgear wg511na 54 mbps wireless...
September 3, 2009 at 08:57:12
Specs: Windows 7, i7 core
I installed the software off the netgear cd, and
it installed fine. it then asked me to shutdown
and install the pci card. So i do all that, and on
boot up its supposed to start the installation of
the drivers. heres my problem. it doesn do
Im not sure if its a win 7 problem or if its my

See More: Netgear pc card wont install hardware drivers

Report •

September 3, 2009 at 10:16:30
Why are you installing the software, THEN installing the that what the instructions say? Normally you should install the card 1st.

Report •

September 3, 2009 at 15:48:15
Yeah, it has a huge warning sticker on it saying cd first before connecting this device. Also I Think that Netgear just doesn't have any drivers for windows 7 atm. would really like this to work right now :<

Report •

September 3, 2009 at 16:51:32
Yes, it is unusal to install the software then the hardware for a PCI device. Normaly this is the way to do it with a USB device which is hot-pluggable. Not a PCI device which isn't. It is not normal for a PCI device to recognise software that has not been previously linked to it.

Just for laughs, try doing it the conventional way by installing hardware first then the software. I can't do any harm and it might work.

But then, it may be that the software is not Windows 7 compatible. You will need to check the Netgear web site.


Report •

Related Solutions

September 3, 2009 at 17:07:08
Try using the Vista drivers.

Report •

Ask Question