need help with A8MZN-LA mobo

September 22, 2011 at 08:55:56
Specs: Windows Vista
Hello everyone, i'm trying to fix my pc by adding a new video card.
i have a HP Pavilion m7750n with mobo A8MZN-LA it has an integrated video card. my problem is this. I plug in the pc and i can see that IT is ON but my screen shows black, i tried different monitors and the same, i did everything that hp asked me to do and nothing I changed the psu, clean the pc, check for the rams. check the bios and nothing finally they said that i might need a new video card. i really hope this solves the problem, but i don't know what video card to buy i only want something good enough for it, i don't want to spend a lot of money. something similar to the one it has on t right are the specs: please help......

Processor, Operating System and Memory
AMD AthlonTM 64 X2 Dual-Core Processor 5000+ for TRUE Multi-tasking, AMD LIVE!TM Made to Bring It All Together
• 2.6GHz, 512KB+512KB L2 Cache, 2000MHz System Bus
Operating system installed
Genuine Windows Vista™ Premium
GeForce 6150 LE/nForce 430 Chipset
Standard memory
Memory type
Memory slots
4 DIMM (240-pin, DDR2) (two available)
Internal drives
Internal hard disk drive
400GB Serial ATA hard drive
Hard disk drive speed
(7200 rpm)
Optical drive type
SuperMulti DVD Burner
Optical drive speed
16x DVDR, 8x DVD+RW, DVD+RW, 6x DVD-RW, 8x DVD+R DL, 4x DVD-R DL, 5x DVD-RAM, 16x DVD-ROM, DVD-ROM, 40x CDR, 32x CDRW, 40x CD-ROM
System features
Memory card device
15in1 memory card reader
56k modem
Network interface
Ethernet 10/100BT integrated network interface
Video RAM
up to 256MB shared video memory
Internal audio
High Definition Audio, 8 speaker configurable
HP multimedia keyboard
Handheld remote control
HP Media Center remote control with IR (infrared) receiver
External drive bays
2 external optical drive bays, 1 internal HDD bay, 1 external HDD bay
External I/O ports
6 USB 2.0 ports (2 in front); 2 FireWire®-IEEE-1394 ports (1 in front)
Expansion slots
3 PCI slots (1 available) 1 PCI Express x16 Slot(z) (available)

See More: need help with A8MZN-LA mobo

Report •

September 22, 2011 at 09:56:52
Do u hear any beeps when u start the system? If not remove all sticks of memory and fire the system, if u hear nothing then CPU or BOARD is bad but it's rare for a CPU to die.
If the IGP is bad u will hear some beep codes, HP support sucks.

We can not fight new wars with old weapons, let he who desires peace prepare for war - PROPHET.

Report •
Related Solutions

Ask Question