Articles

My Computer Won't Charge While On.

Compaq Presario X1000
February 20, 2006 at 01:47:52
Specs: Windows XP Home Edition, Intel Pentium/ 512MB

Alright, my mother borrowed my laptop, well when I got it back it wouldn't cut on. I figured it the power cord so I went and bought one (universal cord), they said it would work with my computer before I bought it. I also bought a utility cd for my computer. When I first got the cord it worked fine, well then I used the utility cd (maybe just a coincedence) but thats when it got to where it wouldn't charge while it is cut on. At first I thought it had something to do with the cord so I took it back and got a different one. But it still did the same thing then I got to thinking about when it started doing it was right after I used the utility disc so I went back and undid what the utility disc did all but one thing that it wouldn't undo. Now, if the battery is low and you turn it on, it will charge until the battery is fully charged and it will quit charging. If you go into power options it says it is using AC power but the battery keeps going down. I thoght maybe it needs a new battery, but it that was so you could still beable to use the computer on AC power, right? Also, if the battery is low and you try to turn the computer on you have to hold down the power button for a long time before it finally will cut on.

See More: My Computer Wont Charge While On.

Report •


#1
February 20, 2006 at 02:40:54

laptops are the weirdest computers on earth it could be the battery or that the cord isnt the highest voltage so it uses the battery as well to power the comoputer

Report •

#2
February 20, 2006 at 04:25:02

Does this universal power cord supply enough voltage for your laptop? Close enough is not good enough. The current rating also should be more than your name plate rating. And the voltage rating should be equal to the name plate rating. If it is slightly less it may be just barely able to supply enough current to partially charge the battery. It may not be able to run the computer.

Report •

#3
February 20, 2006 at 10:44:38

Your power connector maybe damaged or loose.

Report •

Related Solutions

#4
February 20, 2006 at 11:14:37

Okay, I compared the power packs: My original one: Input: 100-240V~ 1.6A(1.6A) 50-60Hz Output: 18.5V(18.5V) 3.5A(3.5A) LPS
65 WATTS The new one I just bought: Input: 100-230V~ 2A 50/60Hz Output: 15-24V
65 WATTS MAX
I can't purchase an original power pack and I got this one from Office Max, the guy I talked to said it was compatible with my computer and the paper says it is. Why would they say its compatible if it ain't?

Report •

#5
February 20, 2006 at 11:30:15

Maybe it is. Maybe compatibility isn't the problem

Report •

#6
March 3, 2006 at 19:53:33

I have the same problem with my machine. It onl;y happened recently. I have had the machine for over 2 years and it has worked fine until the last 6 months. It has burned up 2 AC adapters and now I am running on a universal. Targus. It will charge normally when booted to safe mode but if it is charging on normal mode and I remove the adapter, then it will not charge again until I turn the machine off. I tend to believe there is a registry setting that has been hijacked or altered as it works perfectly fine in Safe Mode. I can remove and reinsert it without problem. I have done a lot of research and cannot find any type of virus or program that does not allow the computer to charge. I have run virus scans in Safe mode and nothing came up, using AVG 7.0 with the most recent updates. I will continue looking but plan on reformatting and reinstalling Xp pro to see if that fixes the problem.

Config: XP pro SP2, 512 ram, PM 1.4.


Report •


Ask Question