my 16GB Kingston DataTraveler 101 broken?

May 5, 2011 at 06:08:24
Specs: Windows XP

16GB Kingston DataTraveler 101 broken?

helo guys, I bought a 16GB Kingston DataTraveler yesterday, somehow on my first used, it worked perfectly, i transfered all my media files in it, but i accidentally unplug it w/o safely removing it, the other day i tried plugging it again on my laptop but my laptop cannot access it,. my laptop somehow read it but when i open it, it says "Please insert a drive into into drive E:", and when i look in its properties the capacity is all 0 bytes, i tried plugging to other computers but no luck, any help would be appreciated and advance thanks.


See More: my 16GB Kingston DataTraveler 101 broken?

Report •


#1
May 5, 2011 at 08:57:11

If the files are important try 'recuva' to rescue them. You may have to reformat to regain use of it. Always use 'Remove Hardware Safely' to avoid damaging the file system.

Report •

#2
May 5, 2011 at 09:11:16

sir the problem is, everytime i tried to reformat it, its say, "There is no Disk in Drive E:" "Insert a disk, and then try again"...... huhuhu

Report •

#3
May 5, 2011 at 13:14:55

You will need a low level drive formatter, The regular drive formatter can only format what the OS sees which is drive of no size,

Report •

Related Solutions

#4
May 5, 2011 at 15:18:27

You can probably fix the partition on the drive with testdisk. If you don't need to fix it but just want to get it working again then go to Windows Disk Management and delete the partition/s there. Then create new and format.

Report •

#5
May 5, 2011 at 15:41:47

thank you all for replying

i tried low level drive formater, it detected my usb somehow, but it says that "the device is not ready", i think this is a hardware issue, i just wasted $35 on it, i had only used it for only a day, dumb usb..


Report •

#6
May 5, 2011 at 15:49:52

Did you look for the device in Disk Management as I suggested? Post back if you don't know how to open disk management.

Report •

#7
May 6, 2011 at 02:00:41

yes sir, i looked at disk management, somehow it was detected, but the bad news is, disk management says that it has no media in it.. i can\'t find the format action after right cliking the drive, "chnge drive letter and path, properties, and help" are the only thing there..

Report •

#8
May 6, 2011 at 04:45:27

Try deleting the partition first. Then make a new partition and then format. Assign a drive letter if necessary.

If you need to recover files use recuva first. Then follow the instructions I just provided. Get recuva at the link below.

http://www.piriform.com/recuva


Report •

#9
May 11, 2011 at 11:04:02

Might be the same problem issued in another topic.
Click!

Report •


Ask Question