m-systems diskonchip 2000

February 22, 2011 at 14:13:35
Specs: Windows XP
I'm trying to access a 8gb flash card through my PCMCIA port. My system does not plugNplay with this device. When looking via the device manager, there is a yellow exclamation point next to the m-systems diskonchip 2000 device. The driver is version 5.1.2600.0 which from what I can tell from searching the net is the latest driver (from 7/01/2001). Can anyone provide any insight as to what the problem may be?

My system is a Toshiba laptop running XP home edition.

tia,
mitch


See More: m-systems diskonchip 2000

Report •


#1
February 22, 2011 at 14:22:31
Your card reader may not be able to read a card that size. That is a common issue with older readers.

Report •

#2
February 22, 2011 at 14:39:13
Actually, I was just thinking that. I have a brand new netbook by Samsung that has a card reader, so I just tried it on that one. It recognized the card, specified it needed to be formatted, I tried to format it - it ran to the end, then said it couldn't format it. I've never used the m-systems diskonchip device before but now I'm wondering if there isn't some inherent issue with the device.

Thanks for the reply - appreciate your time and thoughts.


Report •

#3
February 22, 2011 at 14:41:18
One other thought...before I even plug the 8gb card in the slot there is a registered failure in the device driver management, so I think there is another issue here besides the 8gb capacity.

Report •

Related Solutions

#4
February 22, 2011 at 15:44:11
So you are saying you have the yellow exclamation point before plugging in the memory card?

Report •

#5
February 22, 2011 at 15:52:39
Yes, that's correct. I rebooted the system and went to the device manager and viewed the pcmcia status' and the m-systems status had the yellow exclamation point.

Report •

#6
February 22, 2011 at 15:57:21
Then you need to configure that device first. I don't know squat about PCMCIA ports.

Report •

#7
February 22, 2011 at 16:13:37
Yeah, I think you're right. But I'm kinda ignorant on how to do this myself. I tried updating and reloading the driver but it's at the latest and greatest driver I could find now. So I'm at a loss as to how to correct this issue - if anyone has any thoughts or ideas, please pass them along.

Report •

#8
February 22, 2011 at 16:55:57
The DOC's usually were used in qnx systems.

Where did you get that drive from?

Oddly there should be a driver for it as I recall, both qnx and beos needed it and there was support for MS products.. It is not exactly a flash memory as such.

"The era of big government is over," said Clinton 1996


Report •

#9
February 22, 2011 at 21:02:25
Okay, sorry, I probably mis-spoke. The flash card I was referring to is an 8gb SD Card that gets read through the PCMCIA m-systems diskonchip port. The PCMCIA port came with both the laptop, and with my netbook. On the laptop the driver for that port is flagged as non-functional. The driver I have for that device is the latest version I could find on the internet - which is quite old - so I wouldn't think the driver is at fault.

Thanks for the reply.


Report •

#10
February 23, 2011 at 05:14:48
Try removing the port from within Device Manager and then reboot. Windows should re-install the port.

Are you running SP3?


Report •

#11
February 23, 2011 at 07:13:33
Well, I uninstalled the m-systems diskonchip port and re-booted. It did not automatically 'see' the port so I went into the device manager and initiated a hardware scan with no new hardware found. So it appeared to be a hardware failure and not a software mishap.

So now the confusing part. I plugged the 8gb sd card in (you know the definition of insanity, right? ya keep doing the same thing expecting different results); there was no hardware found; there was no additional drive showing up under the 'my computer' heading; but the 'safely remove hardware' icon was now being displayed in the tray. The m-systems diskonchip PCMCIA port was still not being displayed under the PCMCIA adapters listing, just the ENE CB-710/712/714/810 Cardbus Controller. When I took a more detailed view/listing of the removable hardware it showed a PCMCIA IDE/ATAPI Controller. So under the IDE/ATA/ATAPI controllers I found a PCMCIA controller with no yellow exclamation point. I'm assuming that the m-systems failure was not related to this problem as I originally thought. All indications within the device driver controller properties show this device as operating normally and having the latest driver installed (version 5.1.2600.5512). But there is no listing of the sd card as a device within the 'my computer' listing to view or format...just the tray icon to safely remove the sd card.

I am running with SP3.

Thanks for the help - appreciate it.


Report •

#12
February 23, 2011 at 08:30:00
Do you use the port for any other purpose? Asking to know if it is actually functioning. Also, try a smaller capacity SD card, if you have one. That will determine if the capacity of the card is the issue.

Report •

#13
February 23, 2011 at 09:11:00
I've never actually used this laptop - it's a friend's - to know if it has worked in the past. I'll try to find a smaller sd card to try though. I'll keep ya posted. Thanks again.

Report •


Ask Question