Articles

MCP6P M2+ Motherboard PCIe Graphics card sudd

January 7, 2010 at 07:32:17
Specs: Windows XP

Hi, I am running an AMD Athlon X2 3.11GHZ 6000+ (AM2 Socket) CPU on a Biostar MCP6P M2+ Motherboard with 3GB DDR@ 800 RAM and a Nvidia Geforce 9500GT 1GB (DDR2) Graphics card. I switched on my PC and the Graphics card wouldn't respond but the onboard graphics does. I have tested my graphics card in another PC and it does work. I have Updated and flashed my bios but nothing seems to work. Any help welcome. Thank you, RedDragon891.

See More: MCP6P M2+ Motherboard PCIe Graphics card sudd

Report •


#1
January 7, 2010 at 08:06:32

I think there is a problem in your board(pci express slot) have u try to put another graphic card?

Report •

#2
January 8, 2010 at 08:03:36

Yes I have tried it with another graphics card but have had no luck. I guess I am just going to have to buy a new motherboard. life sucks and so does Matrix computer warehouse. They lie when they say that you have a guarantee, as soon as you have a problem they refuse to help you. Never ever buy from them. Thanks for your help and consideration...

Report •

#3
January 8, 2010 at 08:21:13

So the card was working previously?

Check to verify the card is fully seated. The lock on the back can interfere.

Have you installed the motherboard chipset drivers?

The motherboard may be under warranty. Check with Biostar.

How long have you had this board?

It was a poor choice for an AM2 socket board.

Do you get video in the POST screens when using the add in card?


Report •

Related Solutions


Ask Question