logitech webcam not detected?

March 11, 2011 at 14:24:16
Specs: windows vista
So i just installed a logitech webcam c210 on my mother's laptop
it worked perfectly fine last night. HOWEVER, this afternoon, when i replugged it into the (same) usb port, it won't be detected. by anything, including logitech software. I look all over the computer, including device manager, but I can't figure it out!!!
please help, this it intended as a birthday gift tonight!!!

See More: logitech webcam not detected?

Report •

March 12, 2011 at 14:17:12
You may need to plug it into a different USB port.

Troubleshooting USB device problems including for flash drives, external drives, memory cards.
See Response 1:

Report •

March 13, 2011 at 13:18:58
no, her computer only has 2 usb ports, and i tried both, multiple times

uninstalling and reinstalling was pretty successful! but i am worried it won't work again at a later time ...

Report •

March 13, 2011 at 15:16:42
Web cams don't need much power.

As long as it's plugged into a USB port directly connected to the mboard (it may not work properly when plugged into an external hub or into a front port on a desktop case), the software is installed for it properly according to the directions that came with it, and it's cord hasn't been damaged, you should have no problems with it.

....the software is installed for it properly according to the directions that came with it....


Usually you DO NOT plug in a more sophisticated USB connected device such as a webcam, printer, or scanner, until AFTER you have installed at least some of the software for it.

DO NOT use Found New Hardware to install drivers for a new device unless the installation directions tell you to do that. In most cases, if you install drivers that way, the device, or it's associated software, or both, will NOT work correctly.

Report •

Related Solutions

March 13, 2011 at 15:35:38
What made you think that I did not use the installation software that came with the webcam?
Or that I plugged it in before installation?

Report •

March 13, 2011 at 17:05:05
You didn't say what you did specifically.

I'm not a mind reader.

It's very common for people to NOT install the software properly.

Report •

Ask Question