Laptop power button not responding

D900T
March 23, 2008 at 10:29:30
Specs: XP, Linux, 3.2 GHz P4, 3 GB
My laptop is a Clevo D900T. I know that it's receiving power and working because I can use the CD player (it can play CDs without booting the computer and obviously needs to access the motherboard etc. to do this) however when I press the power button to actually boot it, nothing at all happens, not even lights or fans. I have even tried pushing the contact underneath it manually. I figure the circuit board with the power button on it has somehow broken but I want to make sure before I spend money replacing it. Is there anything else that could cause this? Also is there any way to force it to power on without using the button?

See More: Laptop power button not responding

Report •


#1
March 23, 2008 at 14:08:06
Did you check the Power button lock. It prevents accidental startup/shutdown.

Possibly small slide Lock at the Power button.

There is nothing to learn from someone who already agrees with you.


Report •

#2
March 23, 2008 at 16:12:08
I don't think this computer has one... besides, manually pushing the contact underneath would have overriden any button lock.

Report •

#3
March 24, 2008 at 13:27:56
Clevo D900T

If you don't have the manual handy get it here:
http://www.clevo.com.tw/en/e-servic...

There is troubleshooting info in it.
I didn't notice any mention of the reset contact or switch you have mentioned.

Generally -
- power button switches are usually very reliable and very unlikely to fail. However, sometimes the button that presses on the switch can become stuck in the on position - if it is stuck in that position the mboard cannot boot - make sure it isn't stuck.
- if certain keys are stuck in the down position on the keyboard the computer may not boot - make sure none are stuck.

- has this laptop been exposed to a liquid spill or rain since it last worked properly?

- have you recently flashed the bios on this computer and since the next attempt to boot this computer has never booted since?
You are taking a big risk when you flash your bios - if the flash fails, and/or the flash chip physically fails while flashing (this is COMMON - these cheap flash chips can only be flashed an unpredictable small number of times), you will have a mboard that will not boot.

- have you recently installed ram that wasn't installed in this computer before, and since then the computer will not boot?

Ram that works in another mboard , or any ram you buy or have lying around, may not work properly, or sometimes, not at all - even if it physically fits and is the right overall type (e.g. SDram, DDR, DDR2, etc.; PCxxxx, xxx mhz) for your mboard. In the worst cases of incompatibilty your mboard WILL NOT BOOT with it installed, and the mboard may not even beep - the ram has to be compatible with the mboard and it's chipset.

See response 5 in this for some info about ram compatibilty, and some places where you can find out what will work in your mboard for sure:
http://www.computing.net/hardware/w...
Correction to that:
Mushkin www.mushkin.com

If you still have the old ram, remove the new ram, install the old ram, and see if the computer will then boot. You must remove the main battery and AC adapter when you do that.

- some bioses support running a CD or other optical drive without you having to boot the computer. As far as playing standard audio CDs or possibly other audio CD formats supported by the drive itself, the drive has all it needs to do that except power and connections to speakers. It takes very little power for it to run, so it may work fine even if the main battery doesn't have enough "poop" to boot the computer.
- how old is the main battery? If it's more than about two years old, it may be no longer capable of being charged up enough to boot the computer, or it may be just plain defective.
- are you sure the AC adapter is working and is capable of charging the main battery? Most laptops will not boot when just the AC adapter is connected, and the main battery must be capable of being charged to at least a minimal level and be charged to at least that level in order for the AC adapter to work to help boot the computer.
- Is it possible this laptop has experienced being dropped or other physical jolts since it last worked? If so, or in any case, see the manual, and make sure the main batterry and hard drive and ram are still installed properly. You must remove the main battery and AC adapter when you check the hard drive and ram connections.

If none of the above helps, there is no way of getting the computer to boot if pressing the power button doesn't result in anything happening. Take it to a local place that is authorized to service Clevo laptops and have them diagnose it.
Or you could look on the Clevo web site to see if you can find a maintenance manual and try taking it apart and tshooting it yourself, but I saw no such there.
If you search for Clevo on the web, you will find a wikpedia "hit" that mentions Clevos are sold under other brand names - if you can figure out what model is the same as yours, you may be able to dig up a maintenance manual from one of the other brand name's web sites.


Report •

Related Solutions

#4
March 24, 2008 at 14:21:54
The computer is about 1 and a half years old. Unfortunately this model has been discontinued so I don't expect to get much help from Clevo.

It's not simply failing to boot, it's acting as though there is no power at all. The LED next to the power button doesn't even turn on when it's pushed. I have tried booting it with the AC adapter only, the battery only, and both, all with the same result: power button completely unresponsive but CD player works.

I haven't recently changed RAM, flashed the BIOS, or spilled anything on it, and the button isn't stuck. The last thing I did was replace the board with the audio jacks on it (which the cd player depends on so I know it's working). I considered I could have loosened the cable between the motherboard and power switch when I took it apart but I have already double and triple checked that connection and it looks fine. If this type of cable were easy to get I would try a new one, but it isn't so I want to make sure other possibilities are ruled out first.


Report •


Ask Question