LAcie Hard Drive Wont Show

August 21, 2006 at 01:38:45
Specs: Windows XP, AMD Athlon 3800 2x512MB
My Lacie External Firewire/USB 2.0 200GB Designed By Porsche Hard drive will not appear in my computer.

When i connect it says new Hardware found and installs, You an see it in the Device Manger but its not in My Computer.

Also in Device Manger it has a weird name here is an image
http://img87.imageshack.us/img87/7683/deviccedi9.jpg

It needs to be formatted also but i cant read it to format.

Can anyone help?


See More: LAcie Hard Drive Wont Show

Report •


#1
August 21, 2006 at 02:00:07
It's shown as a Seagate drive because that's what's inside the USB case. Go into Control Panel/Admin tools/computer management/disk management - the drive should be displayed & you can format it from there - then it will appear in 'My Computer'. Incidentally, you could do with sotying out the missing drivers in the 'Other Devices' section.

"I know that I'm mad, I've always been mad"


Report •

#2
August 21, 2006 at 02:24:47
Ok, i have tried this but the Hard Drive does not seem to show still.

http://img90.imageshack.us/img90/1145/driveeg8.jpg

Any other reason why this is?

Also i dont know where i can get the Missing Drivers, for the drivers in the 'Other Devices' if u know that would be very helpful.


Report •

#3
August 21, 2006 at 05:17:59
Before doing anything, I see other problems that need fixing. What's up with all the question marks under "other devices"???

My guess would be you never installed your motherboard chipset drivers?


Report •

Related Solutions

#4
August 21, 2006 at 05:19:37
Oooops, just noticed that johnr mentioned the same thing about the missing drivers.

Report •

#5
August 21, 2006 at 05:44:25
I have installed those 3 Missing Drivers, And my Hard Drive still isnt reading, in Disk Management or My Computer.

Report •

#6
August 21, 2006 at 05:53:49
OK, as you've now got the missing drivers sorted (this may have been part of the problem if you hadn't got your motherboard drivers installed properly), in Device Manager right-click & uninstall the seagate drive, then unplug it, restart your PC & plug the drive back in again. Hopefully this will kick the system into recognising the USB bit correctly. If it's still only showing in Device Manager, check in the USB section, at the bottom, & see if it's recognised as a USB device at all.

"I know that I'm mad, I've always been mad"


Report •

#7
August 21, 2006 at 09:00:46
Still no luck, i need to some how format this Hard Drive. I dont a Seagate Diag and it found so many Bad Sectors. Maybe that ia the problem. But how do i format a drive i cant access?

Report •

#8
August 21, 2006 at 17:21:33
If you have a lot of bad sectors you will get even more soon. Throw that thing away!

Report •


Ask Question