Is my RLL hard drive dead?

Dell / Mxc051 (inspiron 630m)
June 8, 2009 at 11:58:17
Specs: any, any
Alright, so I have a 286 (an IBM PS/2 Model 30 286 specifically) which had it's original proprietary hard drive dumped some time ago, and replaced with an Adaptec RLL controller card and a Miniscribe 40mb RLL hard drive.

Yesterday, I fire up the machine and get a non system disk error. Run the diagnostics on the PS/2 starter disk and it fails test 1700, returning code 1701 (bad drive controller, drive, or system board).

I boot to an Ontrack floppy and run it. It detects the drive parameters correctly, allows me to enter the bad sector table, but then when I try to have it partition the drive it returns an "unrecoverable i/o error" and cites the drive 0 on the controller is in some manner not accessible.

I try a DOS 5 boot floppy, accessing C causes it to say "general failure reading drive C". Running FDISK locks up the machine with the error "data error reading drive C" on the screen, after which a power cycle is needed because it locked up.

Question at this point: is it the drive or the card that died?

More information now:
I built a Pentium 1 rig to test this out, to eliminate the PS/2 system board/BIOS/etc as a cause. I put the same card and drive into the P1 system, disabled onboard IDE appropriately and all that. The board seems to be incapable of booting to an RLL drive (not surprising) so I booted to a DOS boot disk (Windows ME type I believe).

The RAMDrive goes onto C:, so the fixed disk drive is not being detected as having a partition. I run FDISK, and it detects the drive as being present (something it did NOT do in the 286). It reports, however, that there are no partitions defined (there is in actuality one partition on the drive).

Telling FDISK to create a new primary DOS partition takes it to the "verifying drive integrity" screen, where it switches between 0% and 3% endlessly with no progress. The drive, at this point, is making audible noise (unlike any other noise I've heard from it...kind of like the stepper motor is moving the heads repeatedly into something solid, as if it is not sure where to move them correctly).

Before I risk any further damage to the drive by troubleshooting (though I'm sure any damage is already done), does anyone have any suggestions which do NOT involve upgrading the machine to ATA? It will lose a lot of it's personal value to me if it has a newer technology drive installed; plus, there is no molex plug on the PSU (power is drawn from a connector on the card).

Thanks in advance

See More: Is my RLL hard drive dead?

Report •

June 8, 2009 at 12:15:02
By getting FDISK to create a new primary DOS partition I'd guess you've possibly screwed any data on it already - FDISK is pretty unforgiving. Any unusual noises coming from a drive are bad news & I don't think you've got any software options of recovery. If the data's that important then you're best to get a data recovery company involved - costs have come down & I'm guessing it's not a big drive so it may be your most economic option.

"I've always been mad, I know I've been mad, like the most of us..."

Report •

June 8, 2009 at 12:19:43
The goal is not data recovery, I don't care about what's on it (which is why I didn't think twice about trying to recreate the partition structure). I care because I use this machine, not for productivity purposes, but as a hobby.

Report •

June 8, 2009 at 12:33:57
Try a low level format. That utility is usually on the controller card and can be activated with the dos DEBUG command. You'd boot up with a dos disk having that command and run debug. The most common LLF activation is G=C800:5 at the debug prompt but you should check info about the card to be sure. You need to enter the interleave, cylinders, heads, sectors, precomp and landing zone. It might be best for you to research LLF for MFM and RLL drives if you're not sure.

After a successful LLF do the normal fdisk and format.

Report •

Related Solutions

June 8, 2009 at 12:39:47
I will LLF it, though I do understand that it could totally trash the drive if there is a malfunction while it is happening. I suppose there's nowhere left to turn at this point.

I do have to wonder, and ask though...why/how did this happen? It worked...had to be last week, and then I turn it on and it's just nothing? Heads were parked after last successful use and machine was not physically jarred, though it was moved gently twice during that time.

Report •

June 8, 2009 at 13:14:16
Going through the low level format for the controller card (Adaptec ACB-2072) as outlined in its manual using parameters for this drive (Miniscribe 8450) got me to the "Formatting Drive ..." prompt, then

Controller Error Code: 03, BIOS Error Code: 20
Run this program again (Y/N)?

Of course I said N, if it didn't work that time it would not work again with the same numbers.

Sound like a dead drive?

Report •

June 8, 2009 at 13:29:58
I would think the drive is dead. If it won't LLF it won't fdisk or do a regular format. Those drives were designed to be low level formatted by the user, unlike IDE drives. Often you needed to do that to match the drive to the controller card.

Report •

June 8, 2009 at 14:02:18
Well, DAVE, I trust you're correct, and am strongly inclined to believe the same thing since it simply doesn't want to function. It makes the normal healthy sounds when it powers up, but aside from that, everything else is unhappy sounding bumping noises from the stepper motor.

I've been curious about how exactly the inside of a stepper motor drive is arranged, so maybe I'll take this opportunity to crack it open and tinker with it.

Before I do that, anyone have any suggestions about how to revive it? Stiction doesn't seem to be the problem since it seems to be spinning up just fine.

Interesting...there is a small device on the side with a sticker pointing at it saying "Do not rotate interrupter". I could have sworn that the "interrupter" was in a different position while operating properly. Now the 'interrupter' is in a specific position, different from the one I remember, every time the system is powered on. Could manually adjusting the position of this small arm possibly bring it back to life?

Edit: I've read the hard drive documentation a little more and see connecting an LED to a certain socket on the drive can give me error codes. It flashed once...the code for "Microprocessor ROM checksum error"

I don't think this drive will ever work again, unless I find another circuit board for it (probably cheaper and easier to beg on local classifieds for a whole drive).

Report •

June 8, 2009 at 16:12:27
We had a Sanyo 286, 10mhz, as our first computer - oddball proprietary mboard but it had standard ISA slots and supported standard ISA standards and IBM Dos and MS Dos. It had a 32mb MFM hard drive and a MFM drive controller card when we got it. The bios supported IDE hard drives only. Later on we installed IDE hard drives on it.

I have fiddled (mostly in the late 90's) with lots of MFM and RLL drives and their drive controllers, because I got most of them free or for very cheap at the time and I was curious about them, but I no longer have any of them.

Going by that.......

If your only hard drive is RLL or MFM , you don't normally specify you have a hard drive in the mboard's bios. The bios on old 286 or 386 computers usually supports IDE drives natively but it doesn't normally support RLL or MFM drives. 486 and up bioses certainly do not support them. If you specified you had a hard drive installed in the bios, it probably won't find an RLL drive, and when the bios doesn't find a hard drive, you're going to get error messages from the bios about that .

MFM and RLL drives and their drive controllers are a pain in the ass to set up when the card has not already been set up for the particular drive. In many cases the tech who originally set them up kept the docs that came with the controller card that tells you how to access the programs on the controller card with Dos' Debug because most users didn't want to tackle what was required - when I looked sometimes you could find the docs on the web but often you could not.
The controllers and drives can eat up a lot of time to set up.
Most people were quite happy to get rid of them once IDE drives became plentiful and cheap enough.

If the RLL or MFM hard drive controller card is properly connected to the RLL or MFM drive, and if the card has been set to recognize the drive's type (parameters) properly (the controller often doesn't find the drive at all if that's not right), and if the drive is formatted and has had an operating system properly installed on it, the drive will boot automatically despite there being no hard drive detected in the IDE hard drive only bios.

The drives are relatively noisy. Them making noises IDE drives don't make doesn't necessarily mean there's anything physically wrong with them.

The built in programs on the controller card are usually relatively primitive. You have to know what you doing when you low level format the drive regarding settings or set it's interleave etc.
If you low level format using the program on the card, you usually have to enter the known bad sectors on the drive that are listed on the drive's label - if the drive has developed more bad sectors since, the drive may not work at all, or not work properly until you have partitioned, high level formatted, and tested the drive and marked the additional developed bad sectors with some software, and that is lost when you high level format the drive after that.

Eventually I found older versions of hard drive prep programs such as Disk Manager can set up the MFM or RLL drive much more easily, it has the proper parameters for many drive models in it, it often already knows what specific settings to set the drive to, it can low level format and test the drive to see if it has develped bad sectors that are not listed on the original label on the drive, and it can test the drive to see what interleave yields the best data transfer rate .
However, as I recall, you have to set the correct drive type first in the card's config in order for Disk Manager to be able to find the drive.

You should see a message while booting that indicates the controller card itself is working - in this case, Adaptec something.

You can successfully use most MFM drives as RLL drives and get a better transfer rate when you use a RLL controller card - the Adaptec RLL cards I used yielded much better data transfer rates than most other cards - but you have to use the proper RLL specs and low level format it etc if it was set up as a MFM drive previously.

E.g. The max total no of sectors and bytes is the same for the same total drive capacity .
Used as a MFM drive, it may have 17 sectors per track - as a RLL drive it may have 25 or 26 sectors per track.
The sectors per track X no of heads X no of cylinders must result in about the same total max no. of sectors/bytes, or less.

Report •

June 8, 2009 at 16:40:15

"Interesting...there is a small device on the side with a sticker pointing at it saying "Do not rotate interrupter". I could have sworn that the "interrupter" was in a different position while operating properly. Now the 'interrupter' is in a specific position, different from the one I remember, every time the system is powered on. Could manually adjusting the position of this small arm possibly bring it back to life?"

Don't touch it. The label is there for a reason - manually moving it can damage things physically. I never had to touch it.

Most of the required circuits are on the controller card, not the drive's board. The drive probably does not have a microprocessor. It sounds like the card is faulty and you need to try another card.

Report •

June 8, 2009 at 19:04:49
Eh, Tubes, with all due seems you've not entirely followed my posts in detail here. It looks like you are mistaking the Pentium 1 and the 286 to be the same machine, whereas I have been working with two separate machines.

I did state that I understand, and am not surprised by, the fact that the 586 BIOS would not support booting to the RLL drive...perhaps this can be altered with some tinkering but that is not a concern anyway since it was only put in the 586 system to determine if it could be accessed at all.

The card and drive were 100% working properly in the 286 before this issue happened.

The drive does have a microprocessor, as miniscribe documentation suggests. The LED blinks codes that relate to the drive specifically. Perhaps this is something specific to Miniscribe, but Miniscribe docs definitely suggest that this drive has such a chip on it, and that the error codes pertain to the drive, not the controller.

The 286 in question doesn't have a BIOS. It has a Starter Diskette, in true IBM fashion, designed to make it easy but often complicating things. The "BIOS" supports one type of hard drive - proprietary, which is not in use. Those drives, in working condition, sell for hundreds of dollars now. For this reason, the card and drive were added to the system to replace that proprietary drive sometime before I got the machine. It came to me in complete working order and has been in complete working order until this issue happened.

There was and is no message for this particular card indicating proper operation, nor is there a "press this key for setup" or similar message like on my SCSI adapter. Though I doubt this is what you mean, on the 586's page following the POST, the card is listed as an "ISA Controller", which sounds as though it is detected properly, since "Unknown Device" is what I've seen when using assorted cards that were faulty. Remember, the card and drive worked fine in the 286, and except for the actual seek operations all pretty much self-destructing, nothing has changed after moving it to the 586.

My copy (perhaps all copies?) of Ontrack Disk Manager is specifically written for Miniscribe, it says this while loading. Like I said, it properly detects the drive parameters, but as soon as it does a task where the heads need to be moved, the drive makes an unhealthy noise and it gives an error.

(I am well aware of the noises this drive makes - it has been operating many times in my care so I've heard just about every sound it makes...the sound it is making now is distinctly different. It is a very quick noise, meaning the heads are moving a very short distance, as if the heads are already at the edge of the platters but the motor tries to move them further anyway)

Because of the very limited size of the reply box I'm not sure I've addressed everything. Please forgive me if I've left something out.

PS. I have not tinkered with the interrupter, and I have not cracked the drive open yet.
I do not have another card to test it with...if anyone on the forums has one and sees this, my budget is just about nothing, but I can PayPal you shipping costs if you're willing to give me a card. Much appreciated.

Report •

June 8, 2009 at 19:26:58
If it's a problem with the circuit board there's probably nothing you can do.

Of the info you enter when doing the LLF I don't think there's anything that should be altered from the drive's specs except maybe the interleave. Most RLL's were 3 and MFM's were 4. I think though on a faster PC you could use a lower interleave but going to 2 might be too much. But an RLL should work with either a 3 or 4.

Report •

June 8, 2009 at 20:16:56
3 interleave is what I used, and I used the C/H/S from TH99. The TH99 info is identical to the info from copied off the other. Hopefully those specs are correct...the drive itself doesn't have them identified on it.

Report •

June 8, 2009 at 21:36:56
What's the model number of the drive?

Report •

June 8, 2009 at 22:13:20
Miniscribe 8450

Report •

June 8, 2009 at 22:20:19
I get a C/H/S of 771/4/26, RWC/WPC of 772/128 (may not need both of those for LLF) and landing zone of 810. Is that what you used?

Report •

June 8, 2009 at 22:30:37
Yup, those are the numbers I had found before.

I am not an expert on how these drives work but I do know soon as the drive tries to do any sort of seek operation, the program issuing that request gets an error.

I might have found a local source for a drive/card/both, which would be great to troubleshoot with.

I've also found someone who might be able to walk me through fixing the drive (apparently there's a common problem, something about "fatal track 0 error" where a part inside comes mis-aligned and the drive cannot properly locate any tracks...which matches what I described about the interrupter being in a different spot than I remember)

Of course, once you open one, they don't last long because of dust...but it would be a neat learning experience.

Report •

June 8, 2009 at 23:13:33
I think the interrupter moves as part of normal drive operation. The warning is there to remind people not to move it manually. But I've never thought about fixing one of them. If a drive worked then fine, I'd use it. If it didn't I'd scrap it for the aluminum.

Good luck, I hope you have a good 'learning experience'. You might want to post back and let us know how it went.

Report •

June 8, 2009 at 23:52:30
Well, I said "might". It all hinges on that individual checking his PMs on another site (the user had posted a comment on a photo-rundown of someone disassembling an RLL drive, and in the comment described a method of fixing them, so I sent a PM asking if that's a job that can be done at home, and for any advice I could have)

It does stand to reason, though, that if perhaps the interrupter (or an internal component) had shifted on it's mount, the drive would become confused.

See, the interrupter on this drive is a small metal "flag" you could say which is held on a round motor shaft...with a set screw. It is possible that it has somehow shifted positions, perhaps while the stepper motor was rapidly seeking during that big copy and paste job I did last time it ran...still doesn't explain the error code though.

Oh what a neat experience it would be. Photos included of course if I do it.

Report •

June 9, 2009 at 10:58:41
I did NOT specify I only used these drives on the Sanyo 286. I had the ones I fiddled with working on several computers - an XT clone, a couple 286's, and on at least one 386 and one pentium system. The Sanyo 286 was just our first computer.

Most of the controller cards were 8 bit - the few that were 16 bit I never did find the info to access their built in programs.

About three years ago I gathered up that XT clone, the RLL and MFM controller cards, some other old 8 bit ISA cards, and the two drives I had left, and took them on vacation with me, intending to donate them to someone who posted here that had a computer museum of sorts and wanted them. However, he was moving at the time to a smaller place and couldn't accept them right away. I called him later from where I had travelled to - my brother's place - he said his daughter lived nearby and would pick the stuff up - she never did. I assume the guy's wife didn't want him to have a computer museum anymore. All that stuff was thrown away after my brother had waited many months. I may still have a controller card I missed somewhere, but I doubt it.

Once the controller card was set up for a particular drive and the drive was working, I could transfer them to any PC mboard that has an ISA slot and they worked fine.
In my experience, you DO NOT specify you have a hard drive in the mboard's bios Setup if the only drive(s) you have are RLL or MFM.
For the XT computer, it didn't have a bios Setup - you merely set (a) certain jumper(s) to tell the bios you had a hard drive (and however many floppy drives).

If the drive was working fine with the same controller card before, it should work fine on any PC computer, assuming you didn't un-intentionaly damage the drive or the card or it's two data cables.
You certainly would not need to have to reset anything on the card.
However, it sounds like something malfunctioned before you you removed those from the PS/2 computer

Going by the led error code you got "Microprocessor ROM checksum error", if that's correct, you have a serious problem with either the controller card or the drive - in my opinion it's more likely the controller card - that's not the kind of error you get from a mis-configured drive.
You can't assume there's something wrong with the drive until you are sure there's nothing wrong with the controller card.

Did you unplug the PS on the "586" computer, or otherwise switch off the AC to the PS, before you installed the card? You MUST do that on a computer with an ATX PS to avoid any possibilty of damaging the controller card, or less likely the drive, while installing or removing it!

All 286 computers have a bios Setup, but for the earlier ones the bioses were primitive and you could not access that via pressing a key while booting - you used a specific Setup program on a bootable floppy to access the bios Setup. The Sanyo 286 came with such. The one PS/2 computer I worked on had one available online at the time - I tried it and it worked fine - it had a limited number of possible hard drive types to choose from but there certainly wasn't just one - but as I recall they were IDE drive models ONLY.
In my experience, you DO NOT specify you have a hard drive in the mboard's bios Setup if the only drive(s) you have are RLL or MFM.
I may still have such for the PS/2 computer I worked on somewhere on a hard drive or on a floppy - as I recall it was a Model 30, and it had a Cyrix cpu rather than an Intel one.
Over the years many of the Setup floppies for the earlier 286's have been lost. In many cases a "universal" or generic Setup program you can get off the web may work, but that may not work for a PS/2 computer.

In the later days of them, sometimes when you bought a MFM or RLL drive, it came with a brand specific copy of Disk Manager (or some other drive preparation program - Disk Manger was probably the dominant one) , or you could order that from the hard drive maker, or much later (there was no internet or www for most people when these drives were first released) you could go to the hard drive maker's web site to download that free. If the drive is found to be some other maker's brand, either Disk Manager quits, or you can do some but not all things with it. That still applies to many if not all of the free drive preparation programs you sometimes get along with a retail packaged drive, or when you get it from the manufacturer's web site.
I have such Disk Manager brand specific version floppies for several brands but none for Miniscribe - they came with retail packaged hard drives relatives and friends had purchased and were given or lent to me - but I also bought Disk Manager (a floppy disk) locally and that can be used for any brand of drive. The older versions have extensive RLL and MFM drive support built into them - I don't know if the newer versions still do.

Report •

June 9, 2009 at 12:53:53
I didn't mean to suggest, Tubes, that you were talking about your computers...I thought you had mistaken my two for being the same one...but it's clearly a miscommunication anyway so forget I said anything about it.

Shame about trashing that takes a while but it DOES sell on sites like ebay for outrageous amounts of money. See, I'm only 19...I didn't have a chance to grab this stuff up when it was plentiful. Now I'm looking for a drive (since if the card is bad, it's hopeless...I *need* a card with a power supply lead and not all of them have it).

As I had said - I disabled the onboard IDE (meaning the BIOS of the 586...I got tired of retyping pentium...will by default not recognize any drives of that type.

It's AT so no worries about power supply.

If you're interested in the Miniscribe copy of Disk Manager I can probably put it up somewhere, just let me know.

I may have found a local source for a free or cheap drive and/or card...which would be fantastic.

I heard back from the guy about possibly fixing the drive...the instructions are clear enough that I think I want to try it. That being said, Tubes, you do keep suggesting it could be the card...but I don't have another card to test it with. What I have is a card that in every other way is working, and a drive that in no way is working. I also have the ability to TRY to fix the drive, at the risk of killing it forever, but with the possibility of making it live long enough to prove the card works.

Then again, if the card is dead but the drive is good, I will be screwing the drive and still get no results.

If the card is bad and the drive is bad, well, that's a possibility I don't want to consider.

I'm totally lost here...what should I do?

Report •

June 9, 2009 at 13:15:45
You don't have a way to independently test them. But all things being equal, the drive has the moving parts and is more likely to be the problem.

Report •

June 10, 2009 at 08:25:21
If the 586 has a floppy drive, or if you have one you can connect to it, try booting with a system disk and then using the Miniscribe specific Disk Manager version floppy. It can test the controller card and the drive, or one or the other, and tell you which one is faulty. You probably have to use manual mode to to that.
e.g. (on my bought Disk Manager)
type: dm /m (press Enter)
Diagnostic Services
Run all tests, or select an individual one.
Of course, if the card is faulty, you probably can't reliably test the drive.

If you try low level formatting the drive, do it with Disk Manager - it already "knows" the correct settings to use for these old drives, and it should automatically find bad sectors and flag them as un-usable, even if they are not listed on the drive's label.

In manual mode
System Setup and Configuration
goes to Hard Disk Configuration.

You can examine the parameters for the drives Disk Manager has the parameters for by selecting Non-Standard Disk Parameters.

I may still have some ribbon cables for the MFM/RLL drives.

Report •

June 10, 2009 at 09:59:48
There is no diagnostics item in this version of Disk Manager...(4.02)

Interestingly, the number of cylinders, heads, and sectors detected by DM changes ever time I reboot the computer.

Low level formatting results in:
As soon as the drive performs any operating involving moving the heads, the program reports an error (essentially the fatal track 0 problem, caused by an internal stop moving and making the drive not be able to find track 0) and exits.

Report •

June 10, 2009 at 12:45:00
See your thread about the proprietary CD drive for a new post from me.

I think every version of DM I have has the manual mode available.
Did you use a space between dm and /m? You must for DM!
If in doubt, you should always use a space between a command and a command line switch (e.g. /m), and between multiple switches, on the command line.
Some newer commands will work anyway without the spaces, but for older commands/software you must use spaces.

I haven't found any MFM /RLL ribbon cables yet but I'm sure I have a few somewhere because I remember being surprised I still have some, after I had gathered up those pieces that are now lost.

I haven't found any MFM/RLL controller cards so far........

" Interestingly, the number of cylinders, heads, and sectors detected by DM changes ever time I reboot the computer."

That NEVER happened in my cases. That's sounds like the controller card is having the problem.

"(essentially the fatal track 0 problem, caused by an internal stop moving and making the drive not be able to find track 0)"

Did you add this part yourself?

"...caused by an internal stop moving and making the drive not be able to find track 0"

I don't know why you're fixated on thinking the drive has problem with a mechanism inside it.
As far as I know I had zero problems with the mechanisms inside the drives.
If DM or whatever did not find track 0 on a MFM or RLL drive, or on an IDE drive for that matter, the problem is many times more likely to be caused by the drive developing bad sectors in that critical area, or it could be a false error generated by a faulty controller card but I never had any indication of that with the MFM/RLL drives (that has happenened with IDE drives because of a faulty board on the drive) .
If the controller circuits or the circuits on the drive's board are faulty, it can certainly seem like there's something wrong with the mechanisms inside the drive, but as far as I know I've never encounted such, on any hard drive that has failed.
In many cases with IDE drives it was obvious there was something wrong with the drive's board circuits, because one or more chips on it got too hot to keep a finger tip on - a drive that had that usually made loud thrashing sounds, once the chip got hot enough.

About your ribbon cables.
If there is something wrong with their connection(s), it can appear there is something wrong with the controller / the drive.

- According to what I remember.....

- one of the two ribbon cables has 34 pin connectors. You have to connect that and the ribbon cable with fewer wires to each drive.
- If there are two connectors on the 34 pin cable, it's for a single drive, and some of the wires flip positions between connectors.
- If there are three connectors on the 34 pin cable, some of the wires flip positions between the middle and end drive connectors - a single drive goes on the end connector after the flipped wires. If you have two drives the second drive connects to the middle connector - a single drive won't work or won't work properly connected by itself to the middle connector (it probably won't be detected at all) .

It's easy to confuse floppy data cables with those for MFM/RLL drives.
Floppy drive data cables use the same 34 pin connectors, BUT the wires that flip positions, between two connectors, or beteen the middle and end connectors on athree connector cable, are DIFFERENT ones from those flipped on the MFM/RLL data cables. A single MFM or RLL drive cannot work properly connected to a floppy data cable!

There is one header for the 34 pin ribbon cable, and usually two headers for the one with fewer wires. The proper header with fewer pins must be connected to the drive - one is for a single drive, the other is for a second drive if you have two drives - it probably won't work, or won't work properly, connected to a single drive that is by itself.

Of course.....
The striped side of the ribbon cables should be on the pin 1 end of the row of pins on both ends. The drive can't work properly if one end is on the header backwards, or if it's misplaced on the pins. If any pins are bent, you may need to staighten them in order to get a good connection. If any connector is loose when on the pins, you may need to try another cable that doesn't have such.

If the drive and/or controller stopped working properly on the PS/2 without you having fiddled with the ribbon cable connections previous to that, then it's quite likely something went wrong with the controller card or the drive - but if you did fiddle with them, or in any case, your problem could be caused by a problem with the ribbon cable connections.
I never had a problem with the controller cards, and other than maybe one or two, I never had a problem with the drives, at least not when I used DM, but I did have problems with some of the ribbon cables as I recall.

I composed this for IDE data cables, but the same applies to any ribbon cable:

It is common to un-intentionally damage IDE data cables, especially while removing them - the 80 wire ones are more likely to be damaged. What usually happens is the cable is ripped at either edge and the wires there are either damaged or severed, often right at a connector or under it's cable clamp there, where it's hard to see - if a wire is severed but it's ends are touching, the connection is intermittant, rather than being reliable.
Another common thing is for the data cable to be separated from the connector contacts a bit after you have removed a cable - there should be no gap between the data cable and the connector - if there is press the cable against the connector to eliminate the gap.
80 wire data cables are also easily damaged at either edge if the cable is sharply creased at a fold in the cable.

Try another data cable if in doubt.


Report •

June 10, 2009 at 20:39:00

There is indeed a manual mode, at least the /m switch does work. The command, exactly how I entered it, was:

A:\>dm /m

There is however no 'diagnostic services' or anything remotely similar. There is the option to initialize the drive however, which might be needed before diagnostics can be run. However, anything at all that I try to do results in a very sad sounding noise followed by an error.

I have spoken to someone who worked at a hard drive repair facility working on assorted hard drives of this type, and there is an adjustable stop inside most of them apparently. It is what the actuator arm uses to locate the exact position of track 0 on the platters. If it becomes loose or somehow misaligned, no software solution will work until that stop is repositioned, which is more or less a something you do, then test, then repeat, etc. until it works.

I'm not 'fixated' on thinking the drive is faulty - it's just the overwhelmingly more likely situation. I'm definitely open to the idea that it could be the card or the cables also, but the drive is the only mechanical assembly...of all the possible causes, the most likely one is that indeed, the setscrews which hold the assemblies inside together have been rattled loose. Let's also consider the temperature in the room of this computer - rather cold. Operating it causes it to heat up. After it is switched off, it would cool. This (the different expansion/contraction rates of the assorted metals inside) is nothing short of LIKELY to cause screws to loosen.

At least it's my opinion. It is based on my own preexisting knowledge, the input of the individual who has told me how to fix the drive, examining photos of the insides of this type of drive, and my understanding of the rather strong vibrations that these drives make.

I am NOT saying your suggestions are flat out wrong - I AM saying it just seems most likely, to me, to be the drive.

The cable ends fit on snugly, and their orientation cannot be reversed (like 5.25" floppy drives, there is a key on the connectors). Given that the cables were not bent at any sharp angles and seem to be of a decent quality, I doubt the cables are the issue in this particular case. That said, I do understand and agree that ribbon cables are easily damaged (I have an 80-conductor 40pin IDE cable which is nonfunctional because it was creased...I keep it to donate its connectors sometime since I've found they can be useful to have)

If you can find a set, I'd appreciate an extra (set, that is)...perhaps they could go in the same package as the sound card if you find them (and if we go through on that deal).

The malfunction happened without any 'tinkering' beforehand. Sticking with the theory that an internal part has loosened up and moved slightly, it seems as though either the park command during last use, or the act of spinning up the drive before it malfunctioned caused it (after powering on the drive, the stepper motor immediately moves the heads from the park zone all the way to the opposite end of the platters, where the arm would then hit the stop, at least theoretically)

Since I have no spares of anything, I am left to work with what I have. The only solution, given what I have, is to try to fix the drive, since I can't "fix" the card and the cables appear to be good. Repairing the drive isn't a guaranteed thing...if I open it up and find a giant scratch from the heads crashing or something, it's probably too screwed up to fix, but it's just about the only option I have unless I find another drive, card, cable set, or any combination of those.

Report •

June 11, 2009 at 11:14:40
I found the PS/2 floppies I made.
It was a model 70 I worked on, not a model 30. It was a 386, it had no MCA slots as I recall, and it had a Cyrix upgrade cpu that was equivalent to a 486.
I have the Reference disk for 70/80 (8570/8580), and a shareware MCA Reader program that finds and identifies any of 1,278 devices on a PS/2 system - I don't recall whether it worked on the model 70 - and several other floppies for drivers etc. for it.
It may have been the Reference disk I was able to look at the bios Setup, or at least the drive types you could set the bios to, with.

Report •

June 11, 2009 at 11:18:09
I found the PS/2 floppies I made.
It was a model 70 I worked on, not a model 30. It was a 386, it had no MCA slots as I recall, and it had a Cyrix upgrade cpu that was equivalent to a 486.
I have the Reference disk for 70/80 (8570/8580), and a shareware/freeware MCA Reader program that finds and identifies any of 1,278 devices on a PS/2 system - I don't recall whether it worked on the model 70 - and several other floppies for drivers etc. for it.
It may have been the Reference disk I was able to look at the bios Setup, or at least the drive types you could set the bios to, with.

Report •

June 11, 2009 at 13:08:15
You can download reference disks and other IBM PS/2/microchannel stuff here:

Report •

June 12, 2009 at 10:24:10
Tubes - IIRC the 70 is the same as a 56 but in a different case, which I also happen to have. They do have MCA slots (only 16 bit though, so they look almost exactly like PCI). I also have the upgrade card for mine...a 486SLC. Mine seems to be IBM OEM since it has no branding on it. My machine however did not come with it (8556-045, or 56 SX).

The model 30 286 is a very different beast...rather than 2 disks (ref + diag) like the MCA units, it has only one...a "starter diskette" with limited configuration options (actually I think none), but it does have the full complement of tests. They play a nice annoying extra-loud-high-pitch system beep after each of the tests complete.

DAVE, I think you gave me that link in my thread about the 56 SX when I got it. (the way in which I obtained the 30 286 is exactly the same, but a long story and far off topic). Given how all these files are slowly disappearing from the internet, it makes me want to run a mirroring program on it and put up 45 free websites hosting them.

Report •

June 12, 2009 at 11:45:07
I may have referenced that link before. I found it a couple years ago. There are a lot of links to the old IBM disks but many are dead or incomplete.

Report •

June 12, 2009 at 12:11:43
Sometimes the Cyrix upgrade cpus had IBM branding/labelling on them, rather than Cyrix, particularly if they came with a PS/2 model or other IBM model. Now that you mention it, I think that was the case for the model 70 I worked on. As I recall it had only ISA slots.

You have to load drivers or similar in order for the Cyrix cpu's onboard cache to be used. If the hard drive doesn't have that the cpu doesn't use the onboard cache and runs much slower. My friend's computer had a hard drive that had been reloaded without that, and enabling the cache made a great deal of difference - I have the info and software to do that.

When I was working on the PS/2 model 70, the full support for PS/2s was still available on the IBM Canada site, but it had been wiped from the US IBM site. Going by the dates of the newest files on the floppies that was in Nov. and Dec. of 1998.

Report •

June 12, 2009 at 20:30:08
Oops...the 56 and 57 are the same internally...the 70 is totally different.

You're current Tubes, the 486 cards need a driver. Someone (either you or dave most likely, I forget) pointed me to it in my 56SX thread when I got the machine, and I now have it available for download on a small website project I'm working on. It's a rather rare set of files and sooner or later it will be in rather high demand for enthusiasts with this type of system.

The 486SLC I specifically have only has an FRU label, nothing else. There is a heatsink on the cpu chip itself...therefore I can't ID the chip. Given that 486s generally do need heatsinks I'm not going to remove it...could damage the chip just by removing it at all.

Report •

June 15, 2009 at 08:19:19
I think I vaguely recall the cpu on the model 70 had a heat sink glued to it too, now that you mention it.
I looked at the floppy I have that has the software for enabling the cache on the Cryrix upgrade 486 cpu - it has a file Readcach.1st - in that it says the software tests to see if you have an applicable cpu.

Report •

June 15, 2009 at 18:42:21
If you could please copy the files off that disk and get them online somewhere, I'd appreciate it a lot. I think there were a couple different flavours of those 486SLC drivers and I'm interested in comparing to the copy I already have.

Report •

June 16, 2009 at 13:35:53
According to notes I made on the floppy labels......

Apparently there are two Cyrix upgrade cpus.
486 SRX2 (maybe without the space) , for upgrading from a 386SX ,16 to 25mhz originally
486 DRX2 (maybe without the space), for upgrading from a 386DX, 16 to 33mhz originally

I'm not sure which the above tests for and has the software for. All I know is that cache enabling software worked for the cpu that model 70 had.
In their Properties
Readcach.1st is 646 bytes is 503,963 bytes

I also have a floppy that has a file (a SFX zip) that makes a floppy that has a program that tests for whether the system qualifies for the SX upgrade version. You add your system files to the resulting floppy - then you can boot the computer with the floppy and test.
In it's Properties
Demodisk.exe is 966,911bytes

Any of those the same?
These old downloads are often SFX zip files if they aren't zip files - you can usually examine their contents with WinZip if they have a .exe extension.

If I do get them online somewhere, I might as well place all I have that I think's applicable there.

Report •

June 17, 2009 at 19:18:44
By the way I noticed your Miniscribe specific Disk Manager version is 4.x on your web site, and looking again here I see you say it's 4.02. It seems all mine are 6.x. including the universal version. I also have old brand specific EZ Drive versions.

Report •

June 17, 2009 at 20:41:01
You've probably got it covered but if you need it, I uploaded a generic Disk Manager here:

Report •

June 17, 2009 at 22:10:15
RE: 35
Tubes, it seems like your copy is dramatically different from mine (486 upgrade card drivers). Mine lacks those filenames entirely. Agreed on the uploading all relevant content idea...if you have the time I'd appreciate any old software/utilities along those lines and any drivers you find could go on Driverguide to help people down the road.

RE: 36
I'm somewhat interested in getting your copies of DM...even if I have no immediate use for them I'm sure either I or someone I know will eventually want them.

RE: 37
Thanks Dave, downloaded that. DriverGuide should really have a 'utilities' area rather than clumping together everything as 'drivers'.

Report •

June 18, 2009 at 09:18:45
Try that DAVEINCAPS generic version of DM. It probably has the manual mode I mentioned, and if so, you may be able to determine whether it's the card or the drive that's the problem, although if the card is the problem it may not be possible to determine whether the drive has a problem unless you use a working controller card with it.

Regarding that "universal" utility I have for configuring PnP cards in non-PnP OSs or on mboards with non PnP bioses.

I found it - the one I have is the Intel ICU (ISA Configuration Utility).

If you search the web using: ICU "ISA Configuration Utility"
you'll find many references to it.

(When you search with that there are also frequent references to an EISA configuration utility, not made by Intel, but I know nothing about that one.)

You used to be able to download it from the Intel web site but they don't have it anymore.

Some PnP cards can be configured via jumpers for a non-PnP OS or a non-PnP mboard, but for those that cannot be this utility is often a solution.

I found this...

Software (legacy PNP) Configuration


.....the Intel ICU (ISA Configuration Utility). This utility was shipped with many early plug-and-play devices, and is required for configuration of these devices in a non-PNP environment. In most cases, these devices are a configuration problem only for systems without a plug-and-play BIOS or operating system. It is possible, though, for these devices to cause configuration headaches even with a PNP BIOS and OS. This happens when the BIOS is configured for manual resource assignment and a non-PNP operating system. Although I have encountered this situation several times, it really is the exception rather than the rule. If the PC uses a non-PNP BIOS and is running a non-PNP operating system, for example Windows3.1x over any version of MS-DOS or PC-DOS, the use of the ICU becomes mandatory for proper configuration of Legacy PNP cards.

The Intel ICU was commonly shipped with early PNP cards. It performed the same basic functions that are now performed by the PNP BIOS, but was an on-demand disk-stored utility rather than a part of the mainboard firmware. It was invoked on system startup via a line in the CONFIG.SYS file, which loaded the DWCFGMG.SYS configuration manager driver. In addition, a file called ESCD.RF is written to the root directory of the boot drive, and is used for storing the current ESCD as determined through the ICU.

The ICU had both DOS and Windows components, allowing the user to launch the device configuration utility in either environment, and was completely incompatible with Windows95. Through the use of the ICU, the user could set the desired resources for the ISA PNP cards in the system. There was limited configuration capability for PCI devices, and the user could "lock" the resource assignments when complete. The utility provided a comparatively small number of device definitions upon installation, but the user could add additional devices to the database. All things considered, the ICU provided a workable solution to an otherwise impossible problem.

It was also included with many brand name system's original software installations.

I have it on a CD for an old Packard Bell 486 system that also has Dos / Win 3.1 or Win 3.11 (WFWG) on it.

I made a ICU install floppy from that CD that has the files needed to install it.
There's a note on the floppy - installs in Windows only.
That's Win 3.1 or Win 3.11.
As I recall once it's been installed it can be used in Dos as well as Windows.

Dell and Gateway have info avalaible on the web about how to use it.

Most of the links on the web for where to download it are no longer valid.

However, here I came across a reference to ICUWIN.ZIP

and directions for how to extract it with Dos PKZip, etc.
- Excerpts:

. After the file has been downloaded you must the expand it to a FLOPPY DISK using the -d option to create sub directories. The command should be:

pkunzip -d a:\

3. After the file has been expanded to a floppy you must then go into windows and from your file manager run setup.exe. This will install the program to your hard drive. The setup utility will prompt you several times for information like, directory to install to and making changes to your config.sys. Be sure to say yes to modifying your config.sys, so the following line will be added.


4. Once the installation is complete you must reboot your computer for the changes to take effect.

5. You may now go into Windows and run the Intel ISA Configuration Utility. This utility will show you all of the Plug and Play devices in your system.

I searched for: ICUWIN.ZIP
Apparently there's a Dos only version too.


Also - the last Dos shareware version of PKZIP - PK204g.exe
I used that a lot.
As I recall it works fine as long as the file and directory names abide by the 8.3 max characters standard

Report •

June 18, 2009 at 12:25:31
RE: Card
I've spoken to several people now locally who also believe it's the drive, citing that they've never even heard of a card failing. I've had all kinds of cards of various types fail in one way or another, eventually they stop being detected at all and just cause IRQ issues. But that's a different story.

I use that FTP search agent (filesearching) all the time...very handy. Thanks for hooking me up with the file directly though.

Report •

June 18, 2009 at 13:56:25
Try that DAVEINCAPS generic version of DM in any case.

Report •

Ask Question