Is my hard drive shot?

July 29, 2009 at 21:17:49
Specs: Windows XP
Hi, When I rebooted my computer, I got a message saying that \windows\system32\config\system is either missing or corrupt. It wouldn't load up Windows, of course.
I tried a number of things, including hitting the r to repair and tried to reboot into safe mode but nothing to avail.
So I ended up reformatting my c drive and reinstalled windows.. yes, went through all the trouble to repartition and stuff.
All seemed well until my "new" windows would come to an halt when I tried to setup Windows XP. It took a long time getting my computer name accepted and it completely stopped when I tried to put in a new admin password.
Now I get the same message that says \windows\system32\config\system is either missing or corrupt.
I'm contemplating whether to get a new hard drive or just ditch the machine all together and just buy one of those $200 machines out there unless there's a way to save this computer. Any ideas would be greatly appreciated! Thanks.

See More: Is my hard drive shot?

Report •

July 29, 2009 at 21:41:12
You should be able to find some drive diagnostics software from the site of the manufacturer of your hard-drive. It should tell you if the drive is on it's last legs, however, if there was a sector error when you setup the drive, Windows Setup would have likely caught it and informed you (I'm assuming you did completely blow away the partition as you mentioned).

Report •

July 29, 2009 at 22:39:43
What Ican see also that you have a bad installer. Have you tried to see if you another Os installer with you?

Want A Weekly Update on Latest System Security Problem

Report •

July 30, 2009 at 07:02:35
T-R-A, thank you for your suggestion. Would I be able to install a diagnostic software with a malfunctioning computer? I only have left my netbook and cannot try it on another computer.

lycan20, thank you for your suggestion. Unfortunately, that is my only copy of Windows XP. I recently threw away all of my other copies of older Windows. Errr...

Report •

Related Solutions

July 30, 2009 at 07:47:18

You run diagnostics from a boot disk.

I don't know where Lycan can tell which version of Windows installer you have from what you supplied.

If Lycan means your WinXP CD may be bad then I can accept that.

That said, why in the world would you throw away any software?

Describe what went wrong when attempting to perform a Repair installation.

What type of WinXP CD are you using to install?

Report •

July 30, 2009 at 08:43:55
OtheHill, to answer your question, I had a stack of old software that was just lying around.. Win 95, Win 98 and etc. A few days ago, I got sick of looking at them and threw them away and I think my backup copy went with it. Err... anyway. I'm trying to obtain another copy.. we'll see about that one.

Is there a diagnostic software that you would recommend?

So, to answer your other question, when I reboot the machine I get pass the company's logo and see a message "Verifying DMI Pool Data..."

Then get the "\windows\system32\config\system" missing or corrupt message and underneath it says to Select 'r' to start repair.

When I hit 'r', it reboots itself and starts from "Verifiying the DMI.." until I get the Select 'r' to start repair. It won't even get to Windows. It repeats this step over and over..

All of this is after I repartitioned the HD and reinstalled Windows.
My desktop came with Windows XP Prof. installed and I'm using the recovery CD that came with it. I used this to reinstall Windows.

Report •

July 30, 2009 at 11:38:52
I am not sure if the method is the same with a restore disk but you need to boot to the CD to perform a repair installation.

Are you trying to install a version that came with a different computer? Look at the link below for instructions on how to repair.

Report •

July 30, 2009 at 19:08:53

Thank you for the link but I'm afraid I've already tried this. Many times.

The CD came with the computer that I'm trying to repair. I'm running low on options.

Report •

July 30, 2009 at 19:33:28
What happens when you run the repair? Describe in some detail. There are TWO different spots during the process where you may see an option to repair. You need to choos e the correct one. Read the link again to be sure you have been doing it right.

Try disconnecting all unnecessary external hardware. Like printers, card readers, and of course any external drives of any kind. Then run the repair install again.

Report •

July 31, 2009 at 08:21:57

First of all, just wanted to thank you for keep coming back for me. I can't imagine how boring it must be to help others' computer problems (esp. over the internet) but I greatly appreciate it.

Maybe I'm not understanding the r repair function at all. Hmm.. But now I'm having trouble even getting anywhere since there's some new development:

When I turn on the computer, the company logo shows then "Verifying DMI Pool Data..." shows. (This is where in other computers it would show the type of HD and monitor I have and stuff but for this make and model, that's all it normally says)

Then it says "A read disk error occured: Press Ctrl + Alt + Del to Restart"

When I press Ctrl + Alt + Del, it reboots itself and after the company logo and "Verifying.." comes up, I get the same "Press Ctrl +.. to restart" all over again.

I've tried to boot via CD by frantically pressing all the F1 to F9 buttons (since I'm not sure which one it exactly it is) but I keep getting the "A disk read error occurred" message whether I keep hitting the F keys or not.

Report •

July 31, 2009 at 14:35:40
The logo and all those messages indicate you are in the Windows boot process. Something is stopping Windows from starting.

What you must do is this. Enter the BIOS (setup screens). The keystoke/s for that should be displayed on the screen. You need to do that rather quickly or it will be too late and you will get the screens you describe.

Once you are in the BIOS screens you need to find the line to configure the boot order. You need to change the boot order to have the CD drive BEFORE the hard drive. Another option that should be changed is to DISABLE any logos. That will stop the company logo. You will then be able to see the messages the logo has been hiding.

After you make that change you need to save and exit.

Then insert the WinXP CD and start the computer. When you see a screen saying to hit any key to boot from the CD hit the space bar. Windows should start to install. At that time you need to follow the instruction in the link I provided above.

Do you have files on the computer that you want to save? If so, follow the Repair install instructions. Otherwise you can just have Windows start fresh. The choice is yours.

Report •

August 2, 2009 at 13:19:35
I entered BIOS and changed the boot priority to CD-Rom, Hard Disk and CD-Rom. I would have set the 3rd priority to USB but there were about three choices that started with USB and wasn't very straightforward so I stuck with what I knew.

I couldn't tell which option was to turn off the company logo so I gave up after looking through all the menu options.

After I inserted the CD-Rom and rebooted the computer, the logo showed up and the computer was just "hanging". Nothing happened while I pressed every key until I hit "esc" then I got a message saying "entering boot menu.." then it stopped. I hit "del" then the message said "entering BIOS..." then it didn't do anything.

I waited about an hour to see if there was anything showing up. But nothing. I hit "ctrl+alt+del" and it rebooted itself. (IU repeated this step about five times) Seems like it's waiting for me to hit a button but couldn't tell and nothing I tried worked.

I'm not sure if there is any other key to boot from the CD but I haven't been able to find it yet.

Report •

August 2, 2009 at 23:27:04
" I'm not sure if there is any other key to boot from the CD but I haven't been able to find it yet."

To the looks of it you have a Faulty Cd driver. Have you tried to see if your CD drive's connection is not loose.


Way to go on the support keep it up. As for the CD OS installer I asked him if hehas any other copy of it and then use his original Key serial as a testing method to determine whether his drive is broken or it's only his Cd installer. I would never ask him to use a pirated copy of OS cd installer.

Want A Weekly Update on Latest System Security Problem

Report •

August 7, 2009 at 14:39:30

I opened up the box and checked all of my connections. Nothing seems loose and now I'm back at the \WINDOWS\SYSTEM32\CONFIG\SYSTEM is missing or corrupt message again along with the press 'r' to repair but whenever I hit 'r', it reboots itself but will only come back to both error messages. It will try to boot from the CD but keeps on showing up those error messages.

One more thing, I don't hear any beeps from the POST on boot up. Does this narrow the problem down a bit?

Report •

August 7, 2009 at 15:15:07

If you have a OEM system the r option may not work properly.

The question right now is why didn't you get a good installation when repartitioning and formatting.

Is all the hardware the same as when the computer was new?

Were you getting blue error screens prior to this problem?

Do you have any peripherals connected to the computer now? What you need is a wired keyboard and mouse and a monitor. Nothing more. Have you added any memory to your computer or any add in cards like sound, TV tuner, etc?

Do you know what your memory is and how it installs?

Report •

August 8, 2009 at 09:05:08

To answer your questions:

"Is all the hardware the same as when the computer was new?"

No. Actually, my DVD RW was failing so I replaced it with a new one 3-4 months ago. Haven't had any problems with the DVD RW since and didn't notice anything different until I started getting these messages a couple of weeks ago.

"Were you getting blue error screens prior to this problem?"

No. It just happened suddenly. Although I can hear the fan working extra hard from time to time prior to this problem.

"Do you have any peripherals connected to the computer now?"

No, all is disconnected except for a wired mouse and keyboard.

"Have you added any memory to your computer or any add in cards like sound, TV tuner, etc?"

Other than the new DVD RW, everything is the same.

"Do you know what your memory is and how it installs?"
I have 1 GB (512 x 2) Memory PC2-4200 533 mhz Dual Channel DDR2. It's plugged into the MB directly. Does that answer this question?

Report •

August 8, 2009 at 09:25:52
Yes, all questions were addressed. Faulty RAM could be the source of your current issue. I suggest that you unplug your computer and then remove and snap back in all RAM sticks. Repeat 4 or 5 times with each stick. Performing that task may cause cables to become loosened so check them to verify they are fully seated.

Take care with static discharge by discharging your body before toughing components. If your power supply has an off switch then leave the plug connected and shut off at switch. Then the case will be grounded. Just touch the case before touching hardware.

Then reboot and immediately enter the BIOS (setup) screens to check the boot order again. You need to save the changes when exiting the BIOS. Verify the CD drive and the hard drive are both properly identified in the POST screens when starting the computer.

Clean the Windows CD. Soap and water is OK to use. Insert the CD into the hard drive and boot the computer. Watch for a message to hit any key to boot from the CD.

When you do get the CD to start choose to perform a new installation, not a repair. Then choose to format the partition.

If this results in a bad install then your CD may be defective. Burning a copy of the CD using verification of the files may allow you to make a good copy of the files. You would need the use of a computer with burning capabilities.

Is it possible you have more than one restore disk and the one in use is for a different computer?

Report •

August 8, 2009 at 12:27:50
Thanks, Othehill.
Taking the RAM out and putting it back in a few times fixed the error. I repartitioned again and reinstalled windows and everything looks fine.

I wonder what made the connection loose and what could be done to prevent that from happening again. I still don't get the POST beeps though.

Thanks for all your help!

Report •

August 8, 2009 at 12:35:18
The contacts get corrosion/ oxidation on them. Galvanic action can be one cause if the mating surfaces are of different metals. Gold and Zinc plating are two commonly used metals.

Also, expansion and contraction can play a part.

Most motherboards have a Piezio type speaker integrated on the motherboard. If yours doesn't then you may not hear anything if your speakers are USB. That is, unless you used to hear the single beep.

Report •

August 9, 2009 at 22:20:18
So this means that the problem is caused by the parts is getting eroded?

Want A Weekly Update on Latest System Security Problem

Report •

August 10, 2009 at 05:25:44

Corroded, not eroded. Actually, ozidation is a better term.

Report •

August 11, 2009 at 00:41:29
Thanks othehill

But is it really possible for that to happen in a board? Is that means it got wet?

Want A Weekly Update on Latest System Security Problem

Report •

Ask Question