Iomega Zip not reading 250 mb disk from 1999

Iomega Zip 250mb usb powered starter kit
November 29, 2011 at 10:29:50
Specs: Windows xp
Win xp with external iomega zip 250 drive. Trying to recover
data from 250 M disks from 1999. Running latest iomegaware/
drivers. Drive light works. Drive ejects dsk ok and sounds like
it works...when I insert the disks the pls insert msg remains
on the screen and the hour glass continues forever without
opening disk...any help most appreciated.

See More: Iomega Zip not reading 250 mb disk from 1999

Report •

November 29, 2011 at 14:09:52
I used to have one of those years ago -- didn't realise they were still in use today.

Is it clicking?:

There's a Q&A problem page for Zip Drives here on the Apple website (why Apple I don't know, unless some Macs have internal ones):

Another possible problem I learned is that, like floppy drives, zip drive read/write heads get dirty from the coating on the tape inside the zip disks.
I never had that problem though. You can buy purpose-made cleaning cartridges but Iomega warns against using them, saying they are uneccessary and that they can damage the drive.
See this:

Report •

November 29, 2011 at 19:42:44
Does it show up OK in device manager?

Is the drive connected through USB or parallel port? If parallel you may need to adjust the port settings in cmos.

If all that's OK then the drive or disk must be bad. The drives are cheap enough on ebay.

Report •

November 30, 2011 at 12:56:42
Take a blank disk and see if you can write to it and read it.

1/3 of highway deaths are caused by drunks. The rest are by people who can't drive any better than a drunk.

Report •

Related Solutions

Ask Question