Iomega Prestige 2Tb USB 3.0 Disconnects after Sleep

Iomega Select 2tb 3.5 black external har...
February 28, 2013 at 18:25:53
Specs: Windows 7, Intel i5 / 8gb
I have an Iomega Prestige USB 3.0 2tb external drive that does not reconnect after sleep and/or hibernate. It will remain connected until sleep/hibernate. I use the included "Quick Protect" This is a recent issue ~2 mos., I just now decided to tackle it.
I have updated all software, drivers and firmware as indicated in other sites, and keep everything up to date. Iomega does not have good support, so nothing from them.
To reconnect, I have to either power cycle it or disconnect/reconnect the USB cable. I have also tested using USB 2.0 - seems to be the same. Once recognized, everything work fine until the next sleep cycle.
Sometimes the drive is accessible via Win Explorer, yet Quick Protect says it failed to copy because cannot connect to the drive.
I have been browsing forums for several days now and cannot hit anything that helps. Thoughts on what else to look into?
Gigabyte Ultra Durable GA-Z68A-D3H-B3 v1.0 // Intel i5 // Win 7
8Gb mem / 1Tb mirrored RAID for data + 1 Tb OS & Apps
Thank you.

See More: Iomega Prestige 2Tb USB 3.0 Disconnects after Sleep

Report •

February 28, 2013 at 19:01:00
Go to Control Panel> Power Options> Change plan settings> Change advanced power settings> USB settings> USB selective suspend settings> Disable.

Report •

March 3, 2013 at 16:04:40
OK.. tried this and no progress. Same thing...

Report •

Related Solutions

Ask Question