Iomega 1TB external HDD wont work anymore

Iomega Prestige desktop hard drive - 1tb...
March 3, 2011 at 00:41:45
Specs: Windows XP
Hello there

I have an Iomega external hard drive...had it for about a year now. I didnt get a disc (that I remember) i just plug it in via usb and the computer recognises it and off I go..

The other night the drive was turned on but not connected to the computer when we had a massive storm and lost power.

I went to connect it and it worked fine, but then the power went off for approximately 20 secs again and now when i try to connect it to the computer the computer wont recognise it...

It has power as the power light is on, and the usb connection in the computer is fine because my other hard drive works fine in it...

the external hard drive is making a clicking noise while the power is on...

I really need help as this drive has all the photos of my grandma that passed away 2 months ago, I thought i would keep them on there to be safe but now i cant access it at all

thanks sooo much in advance

See More: Iomega 1TB external HDD wont work anymore

Report •

March 3, 2011 at 01:22:41
I should say that it isnt a clicking noise its a reving noise, like its trying to load up but cant.....and also when I connect it to my computer, the computer doesnt make a noise at all as it is not recognising it

Report •

March 3, 2011 at 07:21:06
First thing to do is look to see if the drive shows up in Windows Disk Management. If you see it there, post all the information listed for that drive.

Report •

March 3, 2011 at 08:08:08
Google "click of death" unfortunately you wont like the results but it describes what has happend to your drive.

Report •

Related Solutions

April 18, 2011 at 12:22:03
I had a similar problem, is not a "click of death" sound, it is a "give me more power" sound. The problem is not in the psu of the case, and not in the hard drive, the problem is in the tiny controller card that is in the metallic Iomega case.
You will have to buy another expernal case (it can be a cheap one), and your hdd will work perfect again. Try a brand Bytecc, I have 5 of them and not ever have a problem

Report •

July 7, 2011 at 03:07:24
Mine stopped working,just beeping noise and power light just flashed,looked at another post and guy said he just banged it on both sides gently (power off) and then restarted.I thought this was a bit captain caveman so went through everything else i found with no joy,as a last resort i just banged it on both sides a few times not too hard ,turned it on and incredibly it worked.I had not used it for over a year and i think in time they just seize up,if nothing else works try this,it did it with another make i had same again before i bought my latest one which is an iomega external,this one i got rid of ,may have worked with a few gentle taps ?.Hope this helps,belive me it worked after i did it.

Report •

August 10, 2011 at 05:03:04
I've just have the same problem with an Iomega LPHD-UPC 500GB. It makes that f---ing "click of death"-like sound and none of my computers recognise it neither in Windows nor Ubuntu. I've tried using a SATA to USB Adapter, plugging the HDD directly into the motherboard, and even the Captain Caveman aproach without results. So long, 350GB of graphic material...

Report •

August 10, 2011 at 05:36:21

Sorry to hear about your data loss. The industry has not done enough to educate folks about making backups of your important data. I hope you will now do so.

Are you aware of commercial recovery companies? The fees are expensive and there are no guarantees. The clicking is usually crashed heads, which can damage the platter but it could be a bearing noise. Go to the link below and listen to the sound files there to further identify your problem.

Report •

Ask Question