Inoperative optical drive

Fujitsu Lifebook a6110 notebook
June 30, 2009 at 00:50:37
Specs: Vista Home Premium SP1, 2 Gb
I had uninstalled Power producer which came
with the laptop but used too much space and I
had no use for.
Using Revo uninstaller, in the process I had
also deleted the
code: {4D36E965-E325-11CE-BFC1-
from the registry as it was also highlighted by
Revo for
Now the n/book does not show the optical
Fujitsu support suggested I do a system
recovery - Now this
is something I do not wish to do because I
lose many
applications and plenty of data.
Is there a way out of it??
How can I get my DVD drive operational
again? without doing
a full system recovery.

See More: Inoperative optical drive

Report •

June 30, 2009 at 05:01:10
Here I am again.

Your main concern is probably your personal data.

If you don't already have that backed up you are taking a big risk. You should maintain at least TWO copies of any data you wish to keep.

Use a flash drive to copy the data to another computer and burn it to disk there. Then you will be free to perform the restore. Chalk it up to experience.

In the future I suggest you either use Windows uninstaller or if the program has its own uninstaller use it. They are there to prevent the kind of problems you now have.

The issue with the optical drive is probably either ASPI layer drivers or the upper and lower filters. Trying to fix that now will no doubt consume more time than the other option.

Report •

June 30, 2009 at 09:18:41
Hill- so good to see you again - and thank you for all the wise
Yes, I have begun to save in exact same way that u
mentioned. Also if u can advise - I have done a full back up of
the pc using Drive Clone Pro on an external Hard Drive, LaCie
Unfortunately the adpater for LaCie burned out and their
support has sent me a replacement, which will take quite
some time to reach me.
I do not know if the LaCie Drive will be operational again - if it
is then the problem is solved otherwise I will have to do a
product recovery.
Could u pls expand on the ASPI layers and the upper and
lower filters that I might try - because I do not wish to do a
product recovery just yet, till I have tried the back up on
Thank you Hill

Report •

June 30, 2009 at 16:17:09
Basically ASPI layer drivers are used for burners, scanners, and other hardware. Unfortunately there are different versions of those drivers. Nero and Roxio use different ones than MSoft. The program you removed probably used them too.

My guess is you may have removed an ASPI layer drier during the uninstall.

The upper and lower filters are another item that get changed. I have read pros and cons about removing them. Some users that couldn't get drives to show were successful after deleting them. My feeling is that MSoft wouldn't have included them if they weren't needed.

All that said I recommend you do your own research if you want to attempt a repair before your restore.

Microsoft Knowledge base is very helpful and there are articles on the ASPI layer drivers and I think the filters at the link below. Google is your friend.

Report •

Related Solutions

Ask Question