I have no dsplay on my monitor! Please Help!!

August 25, 2013 at 09:10:43
Specs: Windows 7
I have a problem and maybe u guys could help me. I just bought myself a new motherboard and a CPU but if i put them into my computer my pc starts but there is no display on the monitor. I have checked my hard drive, my ram and video card and they all work. What could be the problem i think it is not my motherboard because if i start my computer the videocard fans and my cpu stock fan works. Im thinking it might be my CPU. Or might it be something else?

See More: I have no dsplay on my monitor! Please Help!!

Report •

August 25, 2013 at 11:37:56
Are you an experienced builder? Did you bench test the board before installing it in the case? If not, it will be hard to determine whether you have a hardware problem or assembly problem. It doesn't help that you posted zero info about the hardware you're working with. Did you apply thermal paste to the CPU before installing the heatsink? If so, did you use the correct method for the CPU you have - center dot, vertical line, or horizontal line depending on the make/model? When attempting to boot, is there beeping?

EDIT: if it's not the same board, you may to reinstall or repair Windows but 1st you need to get the hardware problem figured out. Why did you swap out the board/CPU?

message edited by riider

Report •

August 25, 2013 at 16:53:17
Silly question but if you have onboard graphics and also an addon card are you sure that you plugged the monitor into the correct socket? A new mobo could be set to the onboard graphics unless the settings are changed in BIOS.

Always pop back and let us know the outcome - thanks

Report •

Related Solutions

Ask Question