I cant download Audio Drivers HELP!

Emachines / W3619
December 2, 2009 at 12:45:22
Specs: Windows XP
I have a E machine W3619 originally running Vista but currently running XP Professional Service pack 3, and it will not play any sounds, music, or anything. I went to the sounds and audio devices and Under Volume it says no Audio device. (I have the manufacture speakers and a monitor that has speakers) I have tried connecting both and neither work.
Under Audio and Voice tabs none of the options are accessible.
Under Hardware it says that High Definition Audio Bus is not installed. When I try to reinstall the driver nothing happens.
I have gone on the manufactures website and it does me no good. I have tried to download from other sites and they always come back saying the system requirements do not meet the driver.
Please someone help me I need to know where and how I can get these or if there is a different problem!

See More: I cant download Audio Drivers HELP!

Report •

December 2, 2009 at 13:33:26
Look at the link below for help. Your problem is Emachines don't supply any WinXP drivers for your model because it didn't come with WinXP.


Report •

December 2, 2009 at 14:13:36
All you had to do was go to the emachines site to look up the drivers. All that are listed are Vista drivers, but it will help you to identify the model. The Vista driver is listed as Sigmatel HD Audio Driver R155.


So then all you need to do is search for XP compatible drivers using that model number. See if this one will work:


Report •

Related Solutions

Ask Question