How to Safely Remove Hardware IF...

April 5, 2009 at 17:30:56
Specs: Windows Vista
Hi guys im new here...

I got a problem this past few days. When i plug in my External HD or Flash Disk, the Safely Remove Icon is missing but when i manage to run the safely remove hardware in my computer (RunDll32.exe shell32.dll,Control_RunDLL hotplug.dll), my devices are not in the list or cannot find or missing although i can view the files inside my External Hd or Flash Disk in my computer.

The Main problem is how to remove my devices safely and also how to recover the safely remove hardware to work normally as before? By the way, one more thing.. I cannot see any eject when i right click my External HD (Western Digital).

Thank you very much, Hope you can help me with this problem.
ahuhu.. i feel so miserable..

See More: How to Safely Remove Hardware IF...

Report •

April 5, 2009 at 20:04:29
Go to and try #5 on the left.

It's a great web site and perfectly safe!

Report •

April 6, 2009 at 01:35:01
by the way im using Vista.. the link is for xp is it safe to use for vista? and one more thing.. the icon missing is not my main problem... T_T

Report •

April 6, 2009 at 13:40:48
Do a restore point. It is clear that some damage has happened to your system.

"Best Practices", Event viewer, host file, perfmon, antivirus, anti-spyware, Live CD's, backups, are in my top 10

Report •

Related Solutions

April 7, 2009 at 00:28:06
i already tried system restore but still the same..
so how could i fix this..

Report •

Ask Question