HDD problem? - really stuck

Hewlett-packard / M300y
July 31, 2009 at 09:35:41
Specs: Windows XP Home SP3, 3.0GHz 2GB
Have a real jam up here. Think it might be the HDD. Comp froze the other day (unusual), so I restarted it. It would go through POST, and then when Windows began to load, it would restart itself. That amusing loop kept going. I tried to start in safe mode. It displays the list of files that it's loading, and every time, it would stop on agp440.sys. I believe, from searching, that it's irrelevant. agp440.sys is simply the last file to be loaded, and disabling it only causes startup to get stuck at the preceding file.

I belive the HDD is working - I can hear it, and I can access the recovery partition. It loads the windows logo, etc, so it must be able to read something. However, if I try the windows recovery tool, it ends in a blue screen that says there was a problem mounting the boot (volume?).

I removed the HDD, and brought it to a friends house, who runs vista. We changed his BIOS to boot from his drive (since when we attached mine, it tried to boot from my IDE drive, and the same problem occurred). Once we had it booting from his SATA drive, it would load the initial Vista screen, then a black line through the display, and then the screen would go blank. It simply stayed that way, all the while trying to access my HDD (which I could hear and feel).

Any ideas on this? I can't understand why his Vista wouldn't load, since it was obviously booting from his SATA disc. I have lots of data on the HDD, and am trying to find a way to resolve this without doing a complete system recovery (i.e. factory config).

Thanks for any help you can offer.

See More: HDD problem? - really stuck

Report •

July 31, 2009 at 11:00:50
You might be able to recover files using Knoppix.

Or, try ubcd, this has various hard disk tools.

Or testdisk, http://www.cgsecurity.org/wiki/Test...

UK MP's are thieving scumbags.
EU members are worse.

Report •

July 31, 2009 at 11:17:34
Run the HDD MFG's Diagnostic software with the HDD in your System. You should find it at the link below.


I suspect you forgot to change the HDD jumper from Master to Slave before you installed it in the Vista Machine.

AGP440.sys was the last file loaded, not necessarily the offending file. The File just above it, Mupp.sys is a common stopping point when loading Windows on a machine with problems.

google using Mupp.sys and you should get lots of hits and some possible solutions.

You should find some info as well, If you search this Site.

What shows up on Scan Disk? I'm sure you've been hit with that just about every time you try to startup.

There is nothing to learn from someone who already agrees with you.

Report •

Related Solutions

Ask Question