harddisk not rolling and dark screen. I ran a sfc /scannow b

April 13, 2012 at 18:01:53
Specs: window 7 home premium, 4gig
the laptop does not power the screen, the hardisk does not roll, the dvd writter seems to be working. the booting indicator light does nt show but the onning light shows. please what can i do

See More: harddisk not rolling and dark screen. I ran a sfc /scannow b

Report •

April 14, 2012 at 14:58:16
Please let me clarify your question.

On your laptop when you turn on the computer, there is no video or backlight to your LCD, There is no disk activity shown by your activity LED, There is disc activity from your optical drive when you put in a DVD. But your power LED is on.

I have no idea how your system file checker fits into this. Unless you ran SFC before the system crashed, in that case you knew something was going wrong with your computer in the first place. Maybe corrupted files?

You need to start troubleshooting.

The first step is going to be to reseat your RAM. So turn off your computer, remove the battery and power, flip it over and remove the memory cover. Now remove both sticks of RAM and just install one back in. Now plug the computer in and try to turn it on. If that doesn't work try the other stick. If that doesn't work, leave one stick in the computer and remove the hard drive. Now power it on and see if you get anything on your LCD.

If that doesn't work, unplug everything and remove the battery, leave the HDD out and press and hold the power button for 30 seconds, put the battery and the ac back in and see if it post.

If that fails, get a flashlight and shine it on the LCD and see if you can see anything on the LCD.

That should be enough to get you started. So report back here when you are done.

Also Please leave the Make and Model of your laptop.

Report •

April 14, 2012 at 20:48:55
i remove one ram, the one on top, plug in the battery and on the system. The system screen display and ask me if want a normall start up, safe mode etc. i chose the normal start up option, it then display the normal "starting windows" for like 2seconds and the screen then black out. and bootin stops with the fan still running. i romove the ram at the bottom and plug the one on top but noting happen the system just on and shut down without displaying anythin on screen though the fan rolled. this also happen when i remove both ram.

Report •

April 15, 2012 at 05:40:37
I have repaired many l655 series toshibas and they have all been reflows. That means that the solder that holds your northbridge chip has fractured and is no longer making an connection to the mainboard. Qstill a decent computer so I would repair it. You will have to have your mainboard replaced or repaired. Sorry

Report •

Related Solutions

April 15, 2012 at 06:13:58
i really appreciate your effort thanks so much. The laptop is not up to two years. please what could have course problem to the northgate chip so i can take precusion and prevent it next time if i can get out of this one. Two the sfc /scannow still cannot repair some files please how do i go about this after i repair the system or i can just ignore it?

Report •

April 15, 2012 at 06:37:09
The main problem would be heat, you need to make sure that your fan and heatsink are free of dust and debris. Next you do not want to flex the system from side to side. Also you don't want to abuse the computer. Treat it as if is was a pane of glass.

Also all the L655 mainboard that do need reflows have the AMD GPU onboard, so if you have the intel grapics this may not be the issue.

Let me know

Report •

April 18, 2012 at 11:02:49
i have intel R graphics. i also retried the reseating, i thought may be i did not do it right the first time i removed the first ram and power the system, it boot!. and ask me if i want to start window normally or in safe mode etc. I chose start wibdows normally and it shows the starting windows with the logo. but the screen balck out and the booting process stopped. the system did no show anything on screen and did not boot at all when i plugged back the ram and when i remove both rams. Please what should i do next. Thanks so much

Report •

April 18, 2012 at 11:55:10
Okay, if you have lines on your LCD, plug in an external monitor and see if it has lines on that monitor too.

Report •

April 18, 2012 at 12:11:34
There is no line this time around. The system graphic was pretty good when i boot it with one ram but will not boot into windows with one ram. And the system will not power screen or boot up when i plug back the second ram.

Report •

Ask Question