Hard Drive (Physical Problem?)

March 13, 2009 at 18:34:14
Specs: Windows XP Home SP3, C2D E6300 / 3072 MB
My current system has two physical hard drives, one with Windows installed (IDE) and the other used for storage (SATA). I have an external hard drive for backup purposes (USB).

I was just going about my usual business when my computer restarted itself, though I'm not sure if this was a random restart as my router also restarted itself for some reason. Whilst restarting, the POST took far longer than usual, and when I finally got into Windows, the storage drive was no longer detected.

I rebooted to enter the BIOS, and again the POST took a while to process, and there was a final line of text that I didn't get to read as I was quickly taken to the BIOS. The drive remained undetected.

What's even more strange is that the external processor light on my computer (the one that lights up whenever there's computer activity) is now permanently lit.

The only conclusion I can come to is the hard drive having some physical problem, but I can't imagine why, and the processor light is beyond me. I haven't overclocked any part of my system, and if it's down to a weak power supply, why would my separately powered router restart itself? If it was a power cut the computer shouldn't have even restarted, and other electrical devices in my house should have shown problems too.

Now whenever I restart my computer the POST takes significantly longer than usual to process, the processor light is permanently on, and the drive is not detected by the BIOS.

I do have the important data backed up so it's not a major loss for me, but still I'd rather have the other data than not.

See More: Hard Drive (Physical Problem?)

Report •

March 13, 2009 at 19:51:29
I would disconnect one drive at a time and boot the machine. Start with the USB, then the SATA. If either one is causing it, you'll see the difference. If that doesn't help, reset the BIOS to defaults.

Congratulations on having a backup in place. You are one of the few.

Report •

March 13, 2009 at 20:10:57
Well I haven't backed up all the data on the drive due to its size, but I have the important files.

Is there any reason either drive would cause this problem? Ideally I'd prefer to keep everything connected because I do regularly access all the drives. Currently the BIOS reads:

Primary IDE Master: [optical drive name]
Primary IDE Slave: [not detected]
Third IDE Master: [IDE drive installed with Windows]
Third IDE Slave: [not detected]
Fourth IDE Master: [not detected]
Fourth IDE Slave: [not detected]

Is there any reason why "Second" isn't there? Should my storage drive be showing up there? I can't actually remember whether it did before.

When I go to the Boot section of the BIOS, the drive doesn't appear as an option at all under any menu, and I know it certainly should appear there.

Report •

March 13, 2009 at 20:40:12
Something doesn't look right. Are you sure you have the cables and the jumpers set correctly on the drives? Is the SATA drive connected to a SATA controller on the mother board.

What does disk management show?
Start run diskmgmt.msc

Report •

Related Solutions

March 13, 2009 at 21:20:49
Well I'm sure all the cables are connected as it was working perfectly fine before the random restart. It was after the restart that all the problems started, and I haven't touched the inside of my computer at all.

Disk Management doesn't show the drive.

Report •

March 13, 2009 at 23:17:16
Try reattaching the sata cable in case it's not connecting properly, if that doesn't work get another sata cable and replace it.
Some have had problems with dicky sata cables.

Report •

March 14, 2009 at 06:23:12
Reset the BIOS to the defaults and see what happens. Otherwise, I would open the box and check the ribbon cables. The windows system drive should be in the #1 IDE controller, at the end of the ribbon cable and set as a master. I don't think it is.

The SATA drive should be on a SATA controller, if in fact the main board supports SATA.

Report •

March 14, 2009 at 12:34:05
If your router restarted at the same time, there may be a problem with the circuit that your system is plugged into. I would have your outlet checked, along with the circuit it's on. If there was a small surge, it could've done damage to an internal PC component, if the surge exceeded the tolerance levels of your power supply. I'm not completely positive though that this is what happened.

"What's even more strange is that the external processor light on my computer (the one that lights up whenever there's computer activity) is now permanently lit."

This light is actually your hard disk activity light. When any of your hard disks are reading or writing, this light flashes. When it's on constantly, it shows that there could be a problem with your hard drive. Sometimes it's on constantly when an IDE or SATA channel that a drive is connected to is turned off in the BIOS. Try resetting your BIOS by removing the big round button battery on the motherboard, leaving it out for a minute, then putting it back in -- doing this with the system unplugged. Doing this will reset any corrupted BIOS settings. You'll have to reset the time and date.

I would also try a different outlet somewhere else in your house, in a room that's on the opposite end of the house.

WinSimple Software

Report •

March 19, 2009 at 06:19:04
Unfortunately removing the battery and resetting the BIOS didn't seem to help. I'm thinking perhaps the cable could be at fault, assuming the drive is still OK.

I forgot that both of my drives are actually SATA. I removed the battery and used a different SATA port for the storage drive, and powered the system on again. To my complete bewilderment neither SATA drive was detected at all, despite me not having even touched the OS drive's SATA cable/port (I only changed the storage drive's port).

I opened up my system again, and used different ports for both drives. Luckily my OS drive was detected again, this time as the Fourth IDE Master. The BIOS reads:

Primary IDE Master: [optical drive name]
Primary IDE Slave: [not detected]
Third IDE Master: [not detected]
Third IDE Slave: [not detected]
Fourth IDE Master: [Windows SATA drive]
Fourth IDE Slave: [not detected]

Problem 1: "Second" IDE Master/Slave isn't present. I don't know if it should be.

Problem 2: "Third" is still present, to which the Windows drive was originally connected, but then I had to change the port because for some reason it lost its detection.

Problem 3: I have four SATA ports, and the storage drive has been connected to three of them without detection. The one it hasn't been connected to is the Fourth (where the Windows drive is connected).

Problem 4: The hard disk light is still permanently lit.

I think I might just get a new computer at this rate -_-

Report •

March 19, 2009 at 06:45:39
Regarding #8, Although SATA drives do not share the bandwidth they do share a controller. So, the slave reference is referring to the second port on that controller. Probably the port adjacent to the one that does show.

FYI, some SATA controllers may not allow a boot device to be connected to them. You would need to consult your manual to see if that may be impacting things. If your one boot drive is working then it wouldn't appear to be the issue.

Where a motherboard has multiple SATA controllers the default settings may be to have some disabled. Check in the BIOS settings to see if the controllers in use are in fact enabled.

Report •

March 26, 2009 at 07:18:20
Well after resetting the BIOS, trying various SATA controllers, power cables and SATA cables, I've come to the conclusion that the hard disk just failed somehow during the random restart. Disconnecting its cables has solved my long POST and the permanent hard disk light.

Is there any way for me to recover the data on it?

Report •

March 26, 2009 at 08:25:04
I use a USB external HD enclosure for data recovery. There are different types, IDE, SATA, etc..

Make sure that you buy the correct enclosure. I buy from tigerdirect.com if I don't feel like going to a store.

Report •

March 26, 2009 at 08:42:40
I guess buying an enclosure is certainly worth a try, though I don't see how it would actually work considering the problem seems to be with the hard drive itself.

I know it COULD work, and this method is used for recovering data from crashed hard drives; I just don't understand its workings from a technical standpoint.

Report •

March 26, 2009 at 09:21:50
The workings are simple in that when the drive is connected to the enclosure, it's running but not booted. So if the system files are corrupt, it doesn't matter because they aren't needed to recover the data.

Report •

March 26, 2009 at 09:32:59
I can understand that if it was a bootable drive with OS files, but as a storage drive it only contains regular files. When connected to my current computer, it's not detected in the BIOS, although it is detected in the sense that the POST takes a lot longer and disk light is permanently on. My other drive boots Windows fine.

Report •

March 26, 2009 at 09:47:06
With the enclosure, it can be connected after the boot process. It's up to you if you want to take the chance. If it doesn't work now, I'm sure you'll have reason to use it in the future if you do a lot with computers. I use mine constantly.

Report •

March 27, 2009 at 17:55:15
A hard drive enclosure probably won't work with this hard drive problem. Unless you may see needing one in the future, I don't recommend spending money on one.

I think your only choice is to send the drive to a professional data recovery service.

WinSimple Software

Report •

March 27, 2009 at 18:12:56

Use the boot option knoppix toram
this will load the os in to the ram, and free up the optical drive,for burning.
May be able to access the drive but, it might not work. its worth a shot.
Download the 696 mb cd, not the dvd


Report •

March 27, 2009 at 19:17:09
Removing an internal hard drive and installing to an external enclosure is the reverse of what you want to accomplish.

Knoppix is an option if the hard drive is spinning and the problem is with the file system on it. Use the ISO from the link provided above and boot to the resultant CDR. If any files are visable you should be able to copy them to any media available. Optical drive, flash drive, external, Network, etc.

Before trying to do anything with the SATA storage drive I suggest you disconnect it for now and concentrate on fixiing the Windows installation.

Check Device Manager to see if all hardware is functioning correctly.

Check the IDE ATA ATAPI controller to see if the hard drive is running in a DMA mode or not (it should be).

Is this a custom built PC? How long has it been in service?

Report •

March 29, 2009 at 14:02:24
It's pre-built to a custom specification (Dec '06), with additional upgrades (Aug '08).

This may be mundane question, but if the BIOS cannot detect the drive, how would Knoppix be able to?

Report •

March 29, 2009 at 14:06:41
Knoppix won't be able to do anything with the drive if it isn't showing in the POST screens.

I came in to this thread late and didn't see where the drive isn't showing in the BIOS.

I assume you did check power and data cables?

Report •

March 29, 2009 at 15:29:12
I think I've fiddled with enough cables to conclude that the problem is down to the drive itself, and I'm grasping at the possibility of using an enclosure to try and recover the data. The data isn't critical though, so I'm not going to consider a professional data recovery service.

Report •

March 29, 2009 at 15:49:08
An enclosure isn't going to help if the drive doesn't show in the BIOS then either it isn't rotating or the controller circuits are shot. Either way, all you are doing when installing it to a USB controller is adding another leyer of electronics. When an external derive quits reading the normal method to recover files is to install the drive internally. But hey, if you think that will work then go for it.

One question concerning the drive. Did you verify the SATA controller you were connecting to was enabled. Also, it might be the SATA controller that is the problem and not the drive. If possible, try connecting the drive to a different controller.

If the drive is rotating I would see if a drive fitness utility can see the drive. Nothing to lose by trying that. If the utility can see the drive then one of the recovery softwares may also be able to see it.

Report •

March 29, 2009 at 18:24:36
I tried all the available SATA controllers along with multiple SATA cables and power connectors, so the problem most likely lies with the drive itself. The random restart obviously caused a problem, although luckily my main drive was unharmed.

The permanent hard disk light and overly long POST indicate a problem, although I'm not sure if I can tell if the drive is rotating.

Report •

March 29, 2009 at 18:39:53
If that is the case it appears you have done all you can do.

Report •

April 28, 2009 at 22:14:05
I initially dismissed this as I bought the drive back in August '08, but it's a Seagate Barracuda 7200.11 500GB ST3500320AS.

I've read about the firmware problems causing drives to fail after a power cycle, where they're no longer detected by the BIOS. I have no idea what firmware was shipped with my drive, and I've already taken the drive out of my computer. Is there any way in which I can try and update the firmware? Would that solve any problems?

Report •

April 29, 2009 at 05:36:58
The link below may be of some assistance.


Report •

April 29, 2009 at 19:58:50
Hmm, is there any way to flash the firmware if the drive isn't detected by the BIOS?

Report •

April 29, 2009 at 20:09:58
Did you look at the link above? There are FAQs there that cover your situation.

Report •

May 2, 2009 at 20:15:19
I did read it but I hit a dead end after I read about the drive spinning up. I tested the drive on an enclosure and I think I do here it spinning, but the troubleshooter carries onto steps I've already tried, and it doesn't mention firmware flashing on undetected drives.

Report •

May 3, 2009 at 06:56:55
I think you are better off with the drive connected internally. The hard drive utilities from Seagate work from a boot disk. That engages the drive at the BIOS level. You are now trying to engage the drive in WinXP. You are adding an extra level of hardware and software to the mix.

If you can't get anywhere when attempting to access the drive in the BIOS then contact Seagate after first verifying the drive is getting power. The cable is good and the controller in use is enabled elsewhere in the BIOS.

Report •

May 3, 2009 at 10:59:51
seagate are having a bad time with these models of hard drive



reliability issues with the 'no detect in bios' issue.

Report •

May 4, 2009 at 17:13:57
Well it seems I'm just another unfortunate consumer of the ill-fated Seagate drive. If only I discovered the firmware problem before my drive bricked on Friday 13th. (Can you believe it?)

I won't be purchasing anything more from Seagate ever again considering their attitude regarding this problem.

Report •

Ask Question