Hard Drive not showing up on Sata dock

November 1, 2011 at 10:34:41
Specs: Windows 7
I have a 3.5 500gb hard drive that was originally part of a seagate external hard drive until I accidentally dropped to where I had to find a new enclosure for it, and it worked fine for a year. Last month, while visiting family, their old comp that was running XP finally died and my youngest sister was crying 'cause all her stuff was in the hard drive. So as a big sis, I took out the old hard drive, took my enclosure and gave it to her and it worked fine. But then I had to take my now exposed 500 gb back home with me. So I stored it in my neoprene laptop cover until I got back home.

At home I have an sata hdd docking station that works for both 2.5 and 3.5 hard drives. Long story short, my docking station does not recognize my 500 gb hard drive. I don't hear anything that would indicate it's reading. I also have a 2.5 320 gb that used to be a wd my passport until it stopped connecting and I had to take it apart. The docking station can read it just fine and I had no problems with it. As for the 500 gb it was my first time connecting it since I took it out of the enclosure a month ago. I'm not sure if the docking station is not able to read a 3.5 hdd or something happened from when I took it out of the enclosure to the travel back home or if I should try getting another enclosure to see if that would work. I did, however, kept that hard drive in a silicon case for the month when I didn't use it, but it was not covered from the travel home which was about 3 hours.

Anyway, any suggestions before going to some drastic measures?

See More: Hard Drive not showing up on Sata dock

Report •

November 1, 2011 at 11:40:52
Try the different enclosure idea.

How do you know when a politician is lying? His mouth is moving.

Report •

November 1, 2011 at 11:55:42
When connecting to the docking station can u feel hard drive platter moving? Can u hear click noise?
3.5 hdd needs additional power to drive platters.

You know the real meaning of peace only if you have been through the war.

Report •

November 1, 2011 at 12:20:22
Nope, I don't hear a noise or feel any vibrations coming from it, unlike the 2.5 which I can immediately feel and hear it working. That's why I suspect that there may not be enough power to get it working. I'll try getting another enclosure and see if that works.

Report •

Related Solutions

Ask Question