Gateway 2000 Solo does not turn on

Nero Version 9
August 2, 2010 at 11:05:33
Specs: Not Relevant, PIII/64 MB RAM
I have a Gateway 2000 Solo Laptop.
-When I plug in the AC adapter , the battery light on the laptop is visible and the light on the adapter is also visible.
-When I turn on the laptop with the adapter plugged in , the power light is visible , but the screen remains blank and there are no beeps or noises.
-When I turn on the laptop without the adapter plugged in , nothing happens at all - no beeps or lights or anything.

See More: Gateway 2000 Solo does not turn on

Report •

August 3, 2010 at 09:07:40
Update: I took the battery out and tried to turn it on with the AC adapter connected , but it still did not work. That should indicate that the battery is fine and is not the problem. I'm not sure what I should try next as I know next to nothing about laptop hardware. Could someone guide me through the troubleshooting process?

Report •

August 5, 2010 at 20:50:35
Update: I connected the laptop to a working monitor and turned it on , but nothing showed up on the monitor. That indicates that the problem has nothing to do with the LCD display or backlight.

I also tried the Fn + LCD/CRT (F3) key combination to see if the problem was that simple.

Also , the exact laptop I have is Gateway 2000 Solo 2200. Also , on the first post , I put the product as Nero Version 9. That was a mistake and I can't figure out how to get rid of that.

Report •

Related Solutions

Ask Question