FX5051 w/ USB on WIndows 7 Home not Working

Altec lansing Fx5051 speaker system
December 11, 2010 at 12:26:17
Specs: Windows 7 Home Premium, i7/6

I have an Altec Lansing 5.1 FX5051 USB speaker system. No matter what I do I can only get maybe 4 of the 6 speakers working, sometimes only 3. I recently acquired a high-end i7 Laptop and its audio out is really only for headphones, so I need to use USB. I thought I can use this speaker system with USB. Prior to this I, I used to have a 5.1 Audigy 5,1 Sound card in my old P4HT system. So I know all the speakers do work.
So far;
.. Windows 7 sees the Altec Lansing FX5051 and it is the Default Sound Device.
.. AL's Properties/Enhancement = 'Speaker Fill' = Enable (Tried Disable All & Def w/ no affect)
.. Driver is Microsoft's USB Generic.
.. Sound / Communication is set to 'Do nothing'

Read a lot around the web with no clear solutions. Could use someone's help.

Thanks in Advance

See More: FX5051 w/ USB on WIndows 7 Home not Working

Report •

December 11, 2010 at 23:31:15
Microsoft USB Generic is only stereo at best. If there were drivers supplied install them propely.

The system is a bit old and does not have Win 7 drivers.

Report •

December 12, 2010 at 05:22:56

Thank you for your input, but there never was a driver for the FX5051. It was a strict plug and play system as noted on the Altec L.., website. Windows 7 recognizes the speaker system no matter what USB port I use, but when I use Configure in Sound properties. I can only get some, but not all the speakers to fire off. Sometimes when I remove the USB and reconnect, it may be another set of speakers that are working. It seems like the Windows is stuck in some 3.1 mode.

Report •

December 12, 2010 at 15:14:08
The driver being installed is probably not compatible with Win 7. Ask the manufacturer for a solution.

Report •

Related Solutions

Ask Question