First couple boots HDD not recognized by bios

October 14, 2009 at 07:39:34
Specs: Windows XP, 2.4Ghz P4 / 512mb
Now I have to admit.....this one has me. I have two of these units that I purchased for my daughters to use. They both have the exact same issue. When I first plug the units in the harddrive is not recognised by the bios. Then I start this ritual of starting it over and over. Eventually it is recognized and then will work indefinetly. I am on one now. I updated to the latest bios. Problem still there. The thing that gets me is that if it was a controller failure, then you would think that it would fail while in windows. Same thing if it was a short or bad solder joint. Then I should get periods of failure while using it. Once I'm in windows XP I can use it all night without a problem. Last night I left it on all night with no issues. I checked Dell's support site to see if there was any issues posted there. The bios sucks, you cannot set any part of the harddrive. Its always auto detect so I can't manually set it up. There is really very few things you can set in the bios. Any ideas guys? I took it apart and cleaned the solder joints and inspected them with a microscope. Thought maybe a broken joint and when the laptop warms up then contact is made. It just seems like once it warms up its fine. I can turn it off and on a thousand times and it will boot fine. Unplug it and let it sit a while and bang......back to the ritual. HELP! What do you think? bad bios chip. Remember, its two units doing this that are exact same model. I have tried other drives that I have with the same result. I tried 5 different drives of variuos size and manufacturer with the same result. When I run the Bios diagnostics it says DST failure when the problem is happening.

See More: First couple boots HDD not recognized by bios

Report •

October 14, 2009 at 07:55:47
It sounds like you have the jumper on the hard drive set to Cable Select. If so, try changing it to Master and Slave for the second drive.

I am also assuming these are PATA IDE drives and not SATA. Can you confirm?

Report •

October 14, 2009 at 07:59:02
Please state the model of the laptop.
The specific model of a brand name system is shown on a label on the outside of the case somewhere, or it can often be determined by going to the brand name's web site.

Some bioses have a setting that allows you to increase the amount of time the bios takes to detect the hard drive(s).
Sometimes you need to increase that amount of time in order for the bios to reliably detect faster hard drives while booting.
E.g. I had a Gigabyte 7ZMMH mboard I had to do that with.

If you don't have that setting, you could try disabling Quick boot or similar.

If this is a relatively old laptop, you may need to use a hard drive with a lower max burst speed.

Report •

October 14, 2009 at 08:19:53
Way ahead of you. I already changed it from quick boot and there are no jumpers on the drives. Its a inspiron 5100 or PPL07L. I already stated that I checked the website for any model specific issues and nothing. I dont have any jumpers but I am in the process of making one out of one for a 3 1/2 ". I am going to try setting for cable select then slave and see if it helps. I appreciate the recommendations and I will update in a few minutes

Report •

Related Solutions

October 14, 2009 at 08:52:33
Alright, lets put this down as a picky bios. Took a Seagate Momentus 60Gig and tried all listed jumper settings. Then I tried a 40Gig IBM Travelstar, same thing, tried all jumper settings. Got the same thing. Then I went to a Toshiba 30Gig and set it as Master, nothing........Slave, nothing.......cable select........bang problem solved on this unit anyway. Now I just need to find a combination that will work on the other unit. I hope that it doesn't go back to the problem when this one cools down. I wont know if its truly fixed until it sits a while unplugged.

Report •

October 14, 2009 at 13:43:06
Morning sickness with computers is not uncommon. As is common knowledge, all materials shrink when cooled and expand when warm. This can cause a flaky connection to open up when a unit is cooled overnight, and make again when the unit is warmed up a little.

Report •

October 14, 2009 at 15:08:16
It should not make any difference how the jumpers are set, except some older bioses won't detect the drive at all if it's set to slave and is by itself on a data connection.
The drives should be detected fine with no jumpers installed.
Normally, when a laptop has only one drive, you only install jumpers when you connect it to a desktop computer and even then you may not need to.

One thing I find odd is Dell lists firmware updates for the hard drives this model could originally have come with under IDE and EIDE drivers:

(Drivers and downloads - Inspiron 1500)

I checked out the hard drive models -
They are all ATA 100 and either 4200 or 5400 rpm.

The Fujitsu models listed there are set to master when no jumpers are installed. I don't know if that applies to all laptop drives, but it would probably be either that or cable select in all cases.

If your initial problem drives are 5400 rpm the bios should have no problem detecting them, but if they spin faster it might.

If your problem isn't heat related, then it could be caused by a buggy bios version.

The currently listed bios version A32 has nothing in it's Fixes and Enhancements info that would indicate a problem with the bios detecting hard drives while booting.

However, newer bios versions almost always include all the Fixes and Enhancements for all previous bios versions.

File Versions: Dell Inspiron 5100 Dell System BIOS - Previous versions

Click on a version, then the link beside Plain Text
Click on Fixes and Enhancements

If you see anything in those notes that indicates flashing the bios should fix your problem, then flash it with the A32 version.

Report •

Ask Question