External Hard Drive I/O Error

June 18, 2009 at 01:42:29
Specs: Windows XP / Vista
I have a brand new FreeAgent | Desk™ 1.0-TB USB 2.0 Drive

After backing up all my data, approx. 120 GB i shut down my desktop and after few hours i wanted to backup some more. but the drive is no longer accessible. I get 2 different I/O error every time i double click on my drive icon on both my desktop with Windows XP SP3 & Sony VAIO with Windows Vista SP2. Please check Screenshots: Error 1 & Error 2

Some of the data in the hard drive was valuable so i used seagate's file recovery for windows and was able to recover the data. The complete contents of the hard drive were accessible for recovery via the software. but the hard disk still gives I/O error and is not accessible. I'm not concerned about the data as i already have it on my other drive.
I Want to format the hard drive and make it usable. Please help.

Anurag Ghorpade.

See More: External Hard Drive I/O Error

Report •

June 18, 2009 at 05:05:46
Have you used the safely remove icon to remove the drive before disconnecting?

Are you using the provided cable that connects to TWO USB ports?

Are you connecting the drive directly to USB ports? Are they USB 2.0?

Report •

June 18, 2009 at 05:24:16
everything is fine... because the drive is detected and the seagate's file recovery for windows was able to recover the data. i tried to format but both my machines, the one with XP and other with vista freeze until i unplug the external drive.

Report •

June 18, 2009 at 05:54:39
How can every thing be fine if the drive is working as expected.

Please answer my questions individually.

Do you have the drive configured for fast removal or optimized for performance?

I don't understand how the drive is showing as a local disk. Are those screen shots from WinXP or Vista?

Report •

Related Solutions

June 18, 2009 at 07:49:42
Somehow i tried to format and it was formatted. took pretty long time as 1 terabyte. i thought all is ok as the drive was accessible. Just to double check, i scanned the drive thorugh the seagate manager and it got stuck on 10% for few seconds and then said that the hard disk is faulty and should be immediately returned if under warranty. and to confirm it also gave me read errors http://www.dtidata.com/resourcecent...

so i'm giving it to seagate service centre as it probably has physical faults, bad sectors. and someone told me that 1TB hard drives are not stable.

Thank you all for your support.

Anurag Ghorpade

Report •

Ask Question