External Hard Drive Appears Empty But Is Not

August 21, 2010 at 21:50:49
Specs: Windows XP
I have an Iomega External Professionall HD - 300 GB.It has worked fine, though I haven't used it in a few weeks.

Today, I connected it. All files were visible in My Computer. As I was attempting to tranfer a video file from my laptop to the HD, I got an error message - I didn't write it down,

Since then, when I open the drive on My Computer, it is empty; there are no icons. However, if I click Properties, it shows that there are 126 gb used and 171 gb free..

So, it seems that the files are still there on the drive, but the icons do not show in My Computer and I can't access them.

I have tried rebooting computer both connected to drive and not connected to drive. Same thing happens.

I have run check disk.

I have scanned it with Malwarebytes.

Any suggestions about rre-connecting with these files?


See More: External Hard Drive Appears Empty But Is Not

Report •


#1
August 22, 2010 at 01:29:28
Download a copy of Ubuntu Linux (it's a free ,iso download so you'll need Nero or whatever to create the actual CD) - boot from it and run the live CD option, with the external drive attached - doesn't install but you can run it from the disk. It will let you see what is on your external drive and copy anything found over to your main drive. When done, reboot to Windows and format the external drive.

"I've always been mad, I know I've been mad, like the most of us..."


Report •

#2
August 22, 2010 at 10:25:44
Thanks very much. I am travelling for the weekend, and can try the linux approach. I've done this in the past. That will likely work to retrieve the data.

I was hoping there might be something to restore the connection through Windows.

If you have other ideas, please let me know.

Thanks again.


Report •

Related Solutions


Ask Question