eSata not working

March 18, 2009 at 21:15:25
Specs: Windows XP
I recently purchased a ThermalTake BlacX drive that is able to connect via eSata. I've tested it and it works on USB, but when I try the eSata it doesn't pick up anything at all. I did some digging around online and people mentioned installing a JMicron driver, but whenever I try to install it, it says that a SCSI adapter is not found. Does anyone have any idea?

I am using an Asus P5NSLI motherboard on Windows XP sp2.

2.8c 800mhz fsb
2 gb 512x4 geil dual channel
asus p4p800 se
60 gb ibm 7200 rpm
80 gb maxtor 7200
300 gb seagate 7200
thermaltake va3000 tsunami
evga geforce 6800gs 256mb

See More: eSata not working

Report •

March 18, 2009 at 21:16:46
Please ignore the system specs in my signature, they are outdated.

Report •

March 19, 2009 at 05:34:59

Try the driver download here.

Report •

March 19, 2009 at 13:20:52
I've tried those drivers, but the drive still doesn't appear at all. I've double checked all connections and they are secure.

Report •

Related Solutions

Ask Question